AMBER 99SB-ildn force field and lipids

I am having trouble running energy minimization after inserting lipids into a box (using insert-molecules command and a pdb file for a micelle) with a protein. Each time I try this, I get errors that the number of coordinates dont match. Ex:

Fatal error: number of coordinates in coordinate file (micelle-box.gro, 142773) does not match topology (, 179213)

Some times the gro file has more atoms that the topology file.

I tried editing the SOL number at the bottom of the topology file to equate these numbers (for every 1 I add, the total increases by 4) but that just led to more errors.

Is the problem that my force field is not compatible with lipids?

This error is due to you not keeping correct count of the number of molecules you have actually inserted into the system.

Go back to the start, do insertions step by step, one molecule type at a time, run grompp at each step with the updated .top file (this will throw up the error you already encountered if you count incorrectly), and ensure that you get the correct number of each type of molecule added at each step.

I found that the source of the errors was that Gromacs doesn’t recognize the residue name “DPC”, which is the name used in the pdb file of the micelles I’m inserting. I tried typing:

#include ‘dpc.itp’

at the top of the micelle pdb file I’m inserting, but gromacs still didn’t recognize DPC as a residue. Do you know how I might fix this?

Note: the files I’m using are from Dr. Tieleman’s page

Do you have a dpc.itp file? What does it contain? What is the name used for the DPC molecule within that file, under the [ moleculetype ] section? That is what you need to use within the .top when telling grompp how many molecules are in the coordinate file.