Building gromacs under windows nvcc fatal : unknown option '-std:c++17'

GROMACS version: 2021.5
GROMACS modification: No
As a win10 user
I can compile gromacs 2020.6 but I can’t do this on new gromacs requires c++17 with cmake-gui, how can I change ‘-std:c++17’—>‘std=c++17’ in cmake or msvc…
(If topic is not related for this forum u can delete it)