Building Gromacs with MiMic QM/MM

GROMACS version:2021
GROMACS modification: No
Here post your question

Dear developers and users.
Could I get some advice on installation please?

While I successfully installed the gromacs 2021 and the CPMD, I failed building the gromacs with MiMic QM/MM support.

First, I installed CPMD. Then, according to the installation guide (Installation guide — GROMACS 2021 documentation), I installed “The MiMiC Communication library” without any error.
Lastly, I build the gromacs 2011 with flags "
and got the following error.

CMake Error at cmake/gmxManageMimic.cmake:36 (find_package):
By not providing “FindMimicCommLib.cmake” in CMAKE_MODULE_PATH this project has asked CMake to find a package configuration file provided by “MimicCommLib”, but CMake did not find one.

Could not find a package configuration file provided by “MimicCommLib” with any of the following names:


Add the installation prefix of “MimicCommLib” to CMAKE_PREFIX_PATH or set “MimicCommLib_DIR” to a directory containing one of the above files. If “MimicCommLib” provides a separate development package or SDK, be sure it has been installed.
Call Stack (most recent call first): CMakeLists.txt:423 (include)

“MimicCommLibConfig.cmake” was found at “usr/local/cmake”. However, cmake with “-DCMAKE_PREFIX_PATH=usr/local/cmake” didn’t work (I got the same error above).

I will appreciate your help with this situation.

The file name in the source may be the problem.
During gromacs installation, cmake requires “MimicCommLibConfig.cmake”.
However, CommLib created the “MiMiCCommLibConfig.cmake”.
There is a variation in uppercase / lowercase notation as Mimic vs. MiMiC.
When I rename usr/local/cmake/MiMiCCommLibConfig.cmake to MimicCommLibConfig.cmake and cmake, the error disappears.
After that, errors related to MiMicCommLib have occurred with make step, since the file names in the source code have not been modified.

The old version of MiMicCommLib (Files · docs · MiMiC-projects / CommLib · GitLab) creates MimicCommLibConfig.cmake.
The combination of this version of MiMicCommLib and Gromacs 2019.4 could cmake and make.
However, some errors occurred at make check step.

85% tests passed, 7 tests failed out of 46

Label Time Summary:
GTest = 70.35 secproc (40 tests)
IntegrationTest = 15.05 sec
proc (5 tests)
MpiTest = 1.46 secproc (3 tests)
SlowTest = 10.51 sec
proc (1 test)
UnitTest = 44.79 sec*proc (34 tests)

Total Test time (real) = 307.06 sec

The following tests FAILED:
29 - GmxPreprocessTests (Timeout)
41 - regressiontests/simple (Failed)
42 - regressiontests/complex (Failed)
43 - regressiontests/kernel (Failed)
44 - regressiontests/freeenergy (Failed)
45 - regressiontests/rotation (Failed)
46 - regressiontests/essentialdynamics (Failed)
Errors while running CTest
make[3]: *** [CMakeFiles/run-ctest-nophys.dir/build.make:58: CMakeFiles/run-ctest-nophys] Error 8
make[2]: *** [CMakeFiles/Makefile2:2099: CMakeFiles/run-ctest-nophys.dir/all] Error 2
make[1]: *** [CMakeFiles/Makefile2:2078: CMakeFiles/check.dir/rule] Error 2
make: *** [Makefile:249: check] Error 2

Despite the above error, with running “Sudo make install”, it seemed that the gromacs with Mimic supports was installed as “gmx_q --version” worked.