Error in creating topology for metalloprotein

GROMACS version: 5.1.4
GROMACS modification: Yes/No
I’m trying to built a topology for a protein containing a zinc ion.
Here is the entry of the ion in the pdb input file:
ATOM 4872 ZN ZN A 616 53.141 68.638 31.204 1.00 53.98

I’m using 54a7 ff, in which there is a zinc ion group in the aminoacid.rtp file:
[ ZN2+ ]
[ atoms ]
ZN ZN2+ 2.00000 0
[ bonds ]
[ angles ]
; ai aj ak gromos type
[ impropers ]
; ai aj ak al gromos type
[ dihedrals ]
; ai aj ak al gromos type

I’ve tried changing the name of the ZN group (ZN, ZN2+ etc…) but I always get an error message:
Residue ‘ZN’ not found in residue topology database.

All solution online (including this forum) don’t apply specifically to my problem since a zinc ion is not some unusual ligand and it does appear in the ff files.
Would love some help.

The residue in the PDB file is ZN, but your .rtp entry is for ZN2+. Hence ZN is not found. Change the .rtp entry to ZN and it will work.

I can’t believe I didn’t think about it…
It worked perfectly. Thank you!