Error in Gromacs installation on GPU

GROMACS version: 2022
GROMACS modification: No
Here post your question

Dear Gromacs Users,

I tried to install gromacs 2022 version on Ubundu 20.04 with GPU supported.

versions of auxiliary tools
cmake version 3.16.3

I did following steps,

wget ftp://ftp.gromacs.org/pub/gromacs/gromacs-2022.tar.gz
tar xfz gromacs-2022.tar.gz
cd gromacs-2022
mkdir build
cd build

cmake … -DREGRESSIONTEST_DOWNLOAD=ON -DGMX_BUILD_OWN_FFTW=ON -DCMAKE_BUILD_TYPE=Release -DGMX_BUILD_UNITTESTS=ON -DGMX_PREFER_STATIC_LIBS=ON -DGMX_BUILD_SHARED_EXE=OFF -DGMX_X11=OFF -DGMX_EXTERNAL_BLAS=OFF -DGMX_EXTERNAL_LAPACK=OFF -DGMX_SIMD=NONE -DGMX_GPU=ON

I got following error

I also tried with DGMX_GPU=CUDA , and I could installed , but GPU not supported.
Can anyone support me to install gromacs supported by GPU ?

Thank you in advance !
Kalindu

Hi,

A couple of ways to help narrow down or solve your problem:

If the installation succeeds, are you actually using the newly compiled binary? In your build folder there should be a bin folder with the new binary inside of it. Check if that reports GPU working. If it does, the problem is that your system path is not set to find your new install. Make sure to source the GMXRC file from the installation directory.

If the new binary does not have GPU support, what is the output from your compilation? I believe it should fail or at least give a warning if it can’t add the support.

On an unrelated note, is there a specific reason for why you are turning off SIMD acceleration? You’re leaving a lot of performance on the table.

Regards,
Petter

This sounds to me like your CUDA runtime drivers are not the right ones for your CUDA compiler version. Can you print the output of gmx --version?

Cheers

Paul

Dear @pbauer ,
I posted the screen capture for your reference ,

Hello @Kalindu,

sorry for silence here. I hope you have been able to resolve this by now, but just for completeness, this looks definitely like an issue your runtime. What does nvidia-smi report?

Cheers

Paul

Looking at your screenshot, you compiled GROMACS without any GPU support.

For GROMACS 2022, you should use -DGMX_GPU=CUDA, not -DGMX_GPU=ON. If you’re still getting “GPU support: disabled”, try removing CMakeCache.txt from your build directory and running CMake from scratch.

I also tried with DGMX_GPU=CUDA , and I could installed , but GPU not supported.

Could you please elaborate what error are you getting? The output of nvidia-smi could also be helpful.