Installation problem with GROMACS 2019.4 and cuda 11.2

GROMACS version: 2019.4
GROMACS modification: Yes ( Plumed 2.5.7 patch)
CUDA: 11.2
card: GeForce GTX 1660 TI
GCC: 9.3

Hello Everyone,

I am trying to install GROMACS 2019.4 + PLUMED 2.5.7 on Ubuntu 20.04 LTS with working CUDA 11.2 installation.

cmake options


without DGMX_CUDA_TARGET_SM=“75” also I get the same error. CUDA is mentioned and exported from bashrc also.

Making install in m4
[ 32%] Completed ‘fftwBuild’
[ 32%] Built target fftwBuild
make: *** [Makefile:163: all] Error 2

I am unable to understand origin of this error. Is this problem associated with cuda 11.2?

Mandar Kulkarni

The actual error was about comput_30 and nvcc.

The problem is solved now, quotes for DGMX_CUDA_TARGET_SM was not needed.

Working command is:
cmake … -DGMX_GPU=on -DGMX_MPI=on -DGMX_BUILD_OWN_FFTW=ON -DCMAKE_INSTALL_PREFIX=/home/mandar/softwares/gmx2019_plm25/executables -DGMX_CUDA_TARGET_SM=75 -DGMX_CUDA_TARGET_COMPUTE=75 ; make -j 10 ; make install

Mandar Kulkarni