Installing GROMACS with first manually installing fftw3 library

GROMACS version: 2021.4
GROMACS modification: No
For some reason, I cannot install gromacs with options -

unable to download automatically due to firewall restrictions. I want to install gromacs after first manually installing fftw3 library.
I have fftw-3.3.8.tar.gz file.
I tried below install for fftw3.
./configure --enable-float --enable-sse2 --enable-avx --enable-avx2
make install

then I am trying to give location of fftw3 install, mine is at /usr/local/bin/

Gromacs may be looking for file, as they have given example of setting path as -DFFTWF_LIBRARY=’/path/to/’

But my path (/usr/local/bin/) has only one file - fftwf-wisdom
gromacs doesn’t accept this file.

Can anyone give sequence of command for gromacs installation using fftw3 manual install on PC.

This would be rather odd; there are no relevant binaries that you need from FFTW. You need the libraries and headers. Do you mean you installed an “fftw” subdirectory in /usr/local/bin, or what?

I would strongly recommend a clean approach of installing FFTW with --prefix=/usr/local/fftw (or something similar) because then you can very simply add -DCMAKE_PREFIX_PATH=/usr/local/fftw to find everything that is needed for the installation, as cmake will automatically find the include and lib subdirectories.

Thank you Justin. I will try clean install.