Problem in creating the input of a protein with 2 chains

GROMACS version: 2024.2
GROMACS modification: No
Here post your question

I’m trying to do a simulation with a protein (2 chains), but I’m having a problem putting in the command.

gmx pdb2gmx -f protein.pdb -the protein.gro

-Using the Charmm36 force field.

Inside the folder, the files “Posre_Protein_chain_A. ITP", ‘Prosre_Protein_chain_b.itp’, ‘Topol_Protein_chain_a.itp’, ‘Topol_Protein_Chain_B.itp’, ‘Protein.gro’ and ‘Topol.Top’ are created, but the most relevant information is not included in the topology file ‘’, what would be the correct way to work with this protein?

What information do you think is missing? Multi-chain proteins are written to a file that simply #includes the chain topologies.

Dear Prof. @jalemkul ,

When I place the command on a protein with just 1 chain, instead of the files “topol_Protein_chain_A.itp” and “posre_Protein_chain_A.itp” being within the initial folder of the simulation, their information is inserted within the file, and so following the calculations in a normal way.

But when the simulation is carried out with 2 chains or more, instead of this information being inserted in the file, this information is only inside the main folder, I have already tried to insert it manually inside the file, but the simulation does not occur correctly. The file looks like this:

; Created by:
; :-) GROMACS - gmx pdb2gmx, 2024.2-Homebrew (-:
; Executable: /usr/local/bin/…/Cellar/gromacs/2024.2/bin/gmx
; Data prefix: /usr/local/bin/…/Cellar/gromacs/2024.2
; Working dir: /Users/victormoreira/Documents/forum
; Command line:
; gmx pdb2gmx -f 4ey6.pdb -o protein.gro
; Force field was read from the standard GROMACS share directory.

; Include forcefield parameters
#include “amber03.ff/forcefield.itp”

; Include chain topologies
#include “topol_Protein_chain_A.itp”
#include “topol_Protein_chain_B.itp”

; Include water topology
#include “amber03.ff/tip3p.itp”

; Position restraint for each water oxygen
[ position_restraints ]
; i funct fcx fcy fcz
1 1 1000 1000 1000

; Include topology for ions
#include “amber03.ff/ions.itp”

[ system ]
; Name

[ molecules ]
; Compound #mols
Protein_chain_A 1
Protein_chain_B 1

Unfortunately the #Include present in does not have the desired effect, thank you for any help.

Please explain what this means. You’ve shown an entirely normal multi-chain topology. If you’re getting an error, please tell us exactly what the problem is. A single-chain topology will be written directly to Multi-chain topologies are written exactly as shown. Position restraints for each chain should have their #include statements within their respective chain topology files.

Dear Prof. @jalemkul ,

Using the tutorial available on the Internet (Protein-Ligand Complex), all the initial steps were performed correctly, but when you arrive at the stage of adding ions through the command:

gmx grompp -f ions.mdp -c solv.gro -p -o ions.tpr

The following error month appears:

Program: gmx grompp, version 2024.2-Homebrew
Source file: src/gromacs/gmxpreprocess/grompp.cpp (line 706)

Fatal error:
number of coordinates in coordinate file (solv.gro, 453249)
does not match topology (, 16380)

Likely you have forgotten to update the topology in the solvate and genion steps with the -p option.

Thank you teacher @jalemkul ,

In the solvate stage the following commands were used:

gmx editconf -f complex.gro -o newbox.gro -bt dodecahedron -d 1.0

gmx solvate -cp newbox.gro -cs spc216.gro -p -o solv.gro

But the same error remains.

Please copy and paste the [molecules] section of exactly as it appears.