TIP4P box CG minimization crashes

GROMACS version: 2020.1
GROMACS modification: No
OS: Ubuntu 20.4 emulator in Windows 10

Dear all,

EDIT: TIP3P shows the same problems

I am wondering if anybody has experienced problems running a conjugate gradient minimization of a TIP4P water box (7500 molecules, initial density 0.997). Steepest descent complains about waters not being settled during the first 200 steps or so (last warning step 226), but converges to machine precision in about 4000 steps (step size 0.01). Then, conjugated gradient crashes with the same error in about 600 steps (step size 0.0001).

Here’s what I tried:

  1. I checked the structure output by the steepest descent minimization and didn’t find any bubbles, or anything that looked abnormal.

  2. NVT simulations (annealing from 0 to 300K during 1 ns, then 300K for 1 ns) from the structure minimised by steepest descent run fine. Tried to minimise the structure output by NVT with CG and got the same error.

NPT simulations after NVT show big pressure fluctuations and end up crashing after a few ps (dt=0.0005, both with Berendsen and Parrinello-Rahman coupling)

This issue from a few years ago points out problems with TIP5P, but says specifically that TIP4P works perfectly. https://redmine.gromacs.org/issues/1348

So, I am wondering if that may be a problem with the linux emulator on windows that somebody has experienced before (I don’t have access to a linux machine at the moment), and if anybody has, did you manage to fix it?


How did you generate your water box? Did you fill up your box using the tool gmx solvate together with the option -cs tip4p.gro (pre-equilibrate tip4p water box)?
Kind regards

I have tried that, and also insert-molecules with a gro file containing just one of the water molecules in tip4p.gro (with -rot xyz option), similar results with both approaches.

I finally got access to a Linux machine and all calculations run fine, so it seems to be a problem with the Ubuntu emulator on Windows