Adding SEP and TPO to CHARMM36 ff

GROMACS version:2020.2
GROMACS modification: No

Dear Gromacs Users

I have two phosphorylated residues Serine (SEP) and Tyrosine (TPO) within my pdb model. I am following the step-by-step process on adding a residue to a forcefield as outlined in the following link:

I have updated the residuetypes.dat file within the gromacs installed directory to include the SEP and TPO residues and noted both as Protein. I also copied the charmm36-nov2018.ff folder from the gromacs installed directory and pasted it in my present working directory to edit the merged.rtp file and necessary files. However, I am unsure where to obtain the correct topology defining the atoms, bonds, impropers, etc. for the SEP and TPO residues for CHARMM36 ff.

Can I use CHARMM-GUI or is there a related topology generation tool to obtain these details and adapt the results to the merged.rtp file format?

Thank you, Iris

1 Like

CHARMM36 natively support phosphoserine (SP1, SP2), phosphothreonine (THP1, THP2), and phosphotyrosine (TP1, TP2). You don’t need to do anything aside from renaming the residues in your input coordinate file.

1 Like

Great, thank you Justin! I appreciate your expedient response. I also reviewed the nomenclature for SP1/2 and THP1/2 atoms and it looks like I will need to change SEP/TPO O3P atom to OT.
Best, Iris

1 Like

Hey Justin,

I tried implementing your solution. However, I am still stopped by the error saying THP1211 (211’s the residue number) belongs to the type ‘Other’. The error is the same as before when the name was TPO instead.

Can you please shed some light?

Dear Hermant,

if I remember correctly, you should add the affected residue names to the residuetypes.dat file. You will find the “canonical” copy in the “top” directory of your GROMACS installation (e.g. /usr/share/gromacs/top). Make a copy of it and place it to the working directory, and add lines like “THP1 Protein” etc. This way GROMACS tools will recognize these residues as amino acids.

Hope this helps

Kind regards,


Dear Andras,

Thank you for your response. Your suggestion worked.
Thanks a lot.


Thanks for suggestion

I got this error after changing the names in coordinate file.
Atom -C not found in residue THP1 0, rtp entry THP1 while adding hydrogens.

Make sure there is no space between THP1 and the chain so that the residues of the chain match up such as this. Something probably unique about chain start and terminators giving you that error.

ATOM   2878 HD23 LEU A 100      33.178  28.696  15.759  1.00  0.00      PROA
ATOM   2879  C   LEU A 100      36.233  33.254  15.058  1.00  0.00      PROA
ATOM   2880  O   LEU A 100      37.394  33.567  15.338  1.00  0.00      PROA
ATOM   2881  N   THP1A 101      35.282  34.144  14.783  1.00  0.00      PROA
ATOM   2882  HN  THP1A 101      34.363  33.863  14.519  1.00  0.00      PROA
ATOM   2897  O   THP1A 101      35.525  35.316  17.248  1.00  0.00      PROA
ATOM   2898  N   GLU A 102      36.885  36.879  16.379  1.00  0.00      PROA
ATOM   2899  HN  GLU A 102      37.203  37.389  15.584  1.00  0.00      PROA

PDB files are parsed by number of characters allowed per field and are not space or tab delimited