Error in adding ions using CHARMM36m

GROMACS version:
GROMACS modification: Yes/No
Here post your question

Hi all,

I’m using gromcs with CHARMM36m ff. When I use an earlier CHARMM ff it works well.

When adding ions using
mpirun -np 1 gmx_mpi grompp -f ions.mdp -c pdb_solv.gro -p -o ions.tpr
it writes
ERROR 1 [file topol_Protein_chain_B.itp, line 1818]:
No default Proper Dih. types
This line is:
1 4 17 19 9

Might be related to terminal residue NH2.

Thank you for your time and consideration,
Best regards,

Can you please specify which release you are using that has a problem, and which was correct? This parameter should have been added to the force field several years ago when users encountered the same problem.

Thanks a lot for your response. I really appreciate it.
Sure, I’m using gromacs/2020.2-cpu with charmm36-jul2021.
The previous one that works well with the same gromacs version is CHARMM27 all-atom force field (CHARM22 plus CMAP for proteins).
This may be related to capping a terminal residue with NH2 in pdb2gmx etc.

Thank you for your time and consideration,
Best regards,

I will look and see what is going on with CHARMM36; my statement before was that, to my knowledge, we had fixed this issue in the CHARMM36 port by introducing a parameter by analogy, which was included upstream in the parent CHARMM distribution. It therefore should have been included automatically in our latest port. I was hoping to track down where that might have been lost in the CHARMM36 lineage (which is distinct from the CHARMM27 files produced by the GROMACS team in 2010).

Great, thanks a lot. I really apprecaite it.
As a followup question there is the option to choose CT2 for the C terminal in gromacs -ter flag and we were wondering if:

  1. It means that it caps the residue to CT2?
  2. If so, is there an option to cap the N terminal with ACE?

Thank you again for your time and consideration,
Best regards,


Not via .tdb because there is limited ability to construct atoms. You need to have an actual ACE residue defined as the N-terminal species, and choose “None” as the terminus type when prompted.

Thanks a lot for your help.

Best regards,