Gmx commands not finishing properly

GROMACS version: 2019.6
GROMACS modification: No
Here post your question

Greetings everyone,

I was running gromacs for a while and everything was “perfect” in the sense that all the commands did what they were supposed to.
After upgrading from Ubuntu 19.10 to 20.04 it suddenly stopped working. The problem is:

Running gmx <command> <parameters> leads to the program putting out the “finished” line (e.g. Please Note something) but no citation.
After that, the command line is supposed to show up again, but it isn’t.
Instead, an emply line is sitting there doing notihng.
The only way out is to press control+c

No errors, no other hints what could be wrong.
Also, if I was asking to generate some output, e.g. gmx energy, an empty file is written. Other tools generate output as expected (gmx editconf, grompp, mdrun, …)

Here is the output from simply typing gmx :
user@workstation:/mnt/daten/fettalkohole/oplsaaL/c22oh/test$ gmx
:-) GROMACS - gmx, 2019.6 (-:

GROMACS is written by:
Emile Apol Rossen Apostolov Paul Bauer Herman J.C. Berendsen
Par Bjelkmar Christian Blau Viacheslav Bolnykh Kevin Boyd
Aldert van Buuren Rudi van Drunen Anton Feenstra Alan Gray
Gerrit Groenhof Anca Hamuraru Vincent Hindriksen M. Eric Irrgang
Aleksei Iupinov Christoph Junghans Joe Jordan Dimitrios Karkoulis
Peter Kasson Jiri Kraus Carsten Kutzner Per Larsson
Justin A. Lemkul Viveca Lindahl Magnus Lundborg Erik Marklund
Pascal Merz Pieter Meulenhoff Teemu Murtola Szilard Pall
Sander Pronk Roland Schulz Michael Shirts Alexey Shvetsov
Alfons Sijbers Peter Tieleman Jon Vincent Teemu Virolainen
Christian Wennberg Maarten Wolf
and the project leaders:
Mark Abraham, Berk Hess, Erik Lindahl, and David van der Spoel

Copyright (c) 1991-2000, University of Groningen, The Netherlands.
Copyright (c) 2001-2018, The GROMACS development team at
Uppsala University, Stockholm University and
the Royal Institute of Technology, Sweden.
check out for more information.

GROMACS is free software; you can redistribute it and/or modify it
under the terms of the GNU Lesser General Public License
as published by the Free Software Foundation; either version 2.1
of the License, or (at your option) any later version.

GROMACS: gmx, version 2019.6
Executable: /usr/local/gromacs2019.6/bin/gmx
Data prefix: /usr/local/gromacs2019.6
Working dir: /mnt/daten/fettalkohole/oplsaaL/c22oh/test
Command line:


gmx [-[no]h] [-[no]quiet] [-[no]version] [-[no]copyright] [-nice ]


Other options:

-[no]h (no)
Print help and quit
-[no]quiet (no)
Do not print common startup info or quotes
-[no]version (no)
Print extended version information and quit
-[no]copyright (yes)
Print copyright information on startup
-nice <int> (19)
Set the nicelevel (default depends on command)
-[no]backup (yes)
Write backups if output files exist

Additional help is available on the following topics:
commands List of available commands
selections Selection syntax and usage
To access the help, use ‘gmx help <topic>’.
For help on a command, use ‘gmx help <command>’.


so as you can see, blank line in the end, of which I can create a lot by pressing enter and nothing happens…
The problem persists even after recompiling gromacs from source.

Hope you guys can help me out,
any clue is much appreciated.

Best regards

gmx is a command, that needs a command line option.
see here for more details the option Command-line reference — GROMACS 2021.2 documentation
Best regards

This isn’t correct; gmx itself should print the standard help information and return control to the command line without needing Ctrl+C. If this isn’t happening for the OP, it is a problem, but I would suggest upgrading to a newer version than 2019.6 to see if the issue persists.

thanks for looking into this.
I can upgrade to the latest version for testing purposes,
but unfortunately I need to stick to 2019.6
because the group scheme used by the Flexible Williams ff is not available in later versions anymore and FW is not compatible with Verlet as far as I know.

There is something strange going on here. All help text within <> is missing in your post.
I get:
-nice (19)
To access the help, use 'gmx help '.
For help on a command, use 'gmx help '.

Is those parts also missing in your terminal? Then my guess is that the output is somehow misinterpreted and the shell expects redirected input by interpreting the “<” character.

Hey @hess
as you might see in your answer, this is a “feature” of this forum’s editor. To make them show up, I had to put an escape backslash in front. Sorry for the confusion.

I compiled Gromacs 2021.2 which does finish correctly.
Could this be some incompatibility of 2019.x version with Ubuntu 20.04?
Any Idea how to solve it?