Gmx mdrun -deffnm md_0_1 -nb gpu ** GPU command line error

GROMACS version:
GROMACS modification: Yes/No
Here post your question
Command line:

gmx mdrun -deffnm md_0_1 -nb gpu

Compiled SIMD: SSE2, but for this host/run AVX2_256 might be better (see log).

The current CPU can measure timings more accurately than the code in

gmx mdrun was configured to use. This might affect your simulation

speed as accurate timings are needed for load-balancing.

Please consider rebuilding gmx mdrun with the GMX_USE_RDTSCP=ON CMake option.

Reading file md_0_1.tpr, VERSION 2018.1 (single precision)

Changing nstlist from 10 to 80, rlist from 1 to 1.147

Using 1 MPI thread

Using 8 OpenMP threads


Program: gmx mdrun, version 2018.1

Source file: src/programs/mdrun/runner.cpp (line 1001)

Fatal error:

Cannot run short-ranged nonbonded interactions on a GPU because there is none

detected.

Your GROMACS installation is not optimally compiled (see note about SSE2 vs. AVX2_256) and it seems you do not have a GPU installed on this system. If this is not the case, we will need a lot more information about your hardware and what you have done to verify that any GPU is working properly.

Dear Dr. Lemkul sir

Please find the atatchments to see that gpu is enabled, i hope

What does the .log file say about GPU detection? How did you install GROMACS? What was your exact cmake command?

GROMACS version: 2018.1
Precision: single
Memory model: 64 bit
MPI library: thread_mpi
OpenMP support: enabled (GMX_OPENMP_MAX_THREADS = 64)
GPU support: disabled
SIMD instructions: SSE2
FFT library: fftw-3.3.7-sse2-avx
RDTSCP usage: disabled
TNG support: enabled
Hwloc support: hwloc-1.11.6
Tracing support: disabled
Built on: 2018-03-31 17:12:46
Built by: buildd@debian [CMAKE]
Build OS/arch: Linux x86_64
Build CPU vendor: Intel
Build CPU brand: Westmere E56xx/L56xx/X56xx (Nehalem-C)
Build CPU family: 6 Model: 44 Stepping: 1
Build CPU features: aes apic clfsh cmov cx8 cx16 intel lahf mmx msr pcid pclmuldq pdpe1gb popcnt pse rdtscp sse2 sse3 sse4.1 sse4.2 ssse3 x2apic
C compiler: /usr/bin/cc GNU 7.3.0
C compiler flags: -msse2 -g -O2 -fdebug-prefix-map=/build/gromacs-Fqu8ou/gromacs-2018.1=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -O3 -DNDEBUG -funroll-all-loops -fexcess-precision=fast
C++ compiler: /usr/bin/c++ GNU 7.3.0
C++ compiler flags: -msse2 -g -O2 -fdebug-prefix-map=/build/gromacs-Fqu8ou/gromacs-2018.1=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -std=c++11 -O3 -DNDEBUG -funroll-all-loops -fexcess-precision=fast

i have used the above protocol to install GROMACS dear sir

Apparently not, because the .log file shows you did not enable GPU support. Please provide the actual cmake command you gave to install GROMACS.

Please follow the official GROMACS installation guide and use a recent release:
http://manual.gromacs.org/documentation/current/install-guide/index.html

root@linux-pc:/home/tom# BUILD AND INSTALL^C
root@linux-pc:/home/tom# # CC=gcc CXX=g++ cmake /home/tom/gromacs-5.1.4 -DGMX_OPENMP=ON -DGMX_GPU=ON -DGMX_BUILD_OWN_FFTW=ON -DGMX_PREFER_STATIC_LIBS=ON -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/opt/gromacs
root@linux-pc:/home/tom# CC=gcc CXX=g++ cmake /home/tom/gromacs-5.1.4 -DGMX_OPENMP=ON -DGMX_GPU=ON -DGMX_BUILD_OWN_FFTW=ON -DGMX_PREFER_STATIC_LIBS=ON -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/opt/gromacs
– Could NOT find LibXml2 (missing: LIBXML2_LIBRARY LIBXML2_INCLUDE_DIR)
CMake Error at CMakeLists.txt:552 (message):
Cannot build unit tests without libxml2. Either set
GMX_BUILD_UNITTESTS=OFF or tell CMake how to find a working version of
libxml2.

– Configuring incomplete, errors occurred!
See also “/home/tom/gromacs-5.1.4/CMakeFiles/CMakeOutput.log”.
See also “/home/tom/gromacs-5.1.4/CMakeFiles/CMakeError.log”.
root@linux-pc:/home/tom#

Dear justin lemkul sir

Have i to re install sir

Yes. You need to satisfy all dependencies, and above you get a clear failure message about why cmake failed.

Dear sir

I installed new version successfully after my first installation i could able to run 2020.2 version and after closing the terminal and again opened it, when i type gmx command it says, command not found and install with sudo apt install gromacs and if try installing it, again it is installing 2018-1 old version. How to open new version with gmx command

1

Screenshot from 2020-05-26 01-19-23

There is no need to install another copy/version of GROMACS. What has happened is you have failed to point to the GROMACS installation so that each time you start up a terminal window the OS can find it. When you first installed it, if you notice at the end of the quick and dirty instructions that is at the top of http://manual.gromacs.org/documentation/current/install-guide/index.html there was this command:

source /usr/local/gromacs/bin/GMXRC

That command needs to be run each time that you open a terminal window. You can either do it by hand, or better you put it into the shell command that will do it automatically each time for you. For myself I have to add the above line into my .bashrc script (located in my home directory). Yours may be different, so find out what shell you are running, then add the command appropriately to the shell script/command file that is run each time you open a terminal.