Gmx velacc - Process killed after reading the final frame

GROMACS version: 2020.3
GROMACS modification: No

My aim is to compute the diffusion coefficient of methanol in a zeolite using the velocity autocorrelation function.

I run the following command:

gmx velacc -f traj.trr -nonormalize -n index.ndx -s H-ZSM-5-61MeOH.tpr -o vac_H-ZSM-5-MeOH.xvg

I then select the group corresponding to the methanol molecules, and I receive the following output:

trr version: GMX_trn_file (single precision)
Reading frame 428000 time 59920.000

The simulation time is 60 ns, so all frames got read before the process was killed.
I ran

gmx check -f traj.trr

and it produced the following output:

Checking file traj.trr
trr version: GMX_trn_file (single precision)
Reading frame 0 time 0.000
# Atoms 3711
Reading frame 428000 time 59920.000

Item #frames Timestep (ps)
Step 428572 0.14
Time 428572 0.14
Lambda 428572 0.14
Coords 428572 0.14
Velocities 428572 0.14
Forces 0
Box 428572 0.14

Does anyone have some idea on how I should proceed to troubleshoot the issue?

Thank you very much in advance for your help.



you could try to stop reading before the final frame, in case it is partially corrupt. Use -e 59900 to read up until 59.9 ns.