GROMACS on Windows error: This app can't run on your PC

GROMACS version:2022.2
GROMACS modification: No
Here post your question

Hello GROMACS users,
I am a new user to GROMACS and I am trying to install it on my Windows Dell laptop (Processor: Intel(R) Core™ i5-8365U CPU @ 1.60GHz 1.90 GHz, Windows 10 Enterprise, 64-bit, 16GB RAM). I installed Visual Studio 2022 (including the “Desktop Development wit C++” during install) and Intel oneAPI for MKL (including only the “Intel oneAPI Math Kernel Library” option). I installed the 2022.2 version of Gromacs by extracting it to my c:/ drive. Then, I ran cmake within the x64 Native Tools command prompt:
set CC=cl
set CXX=cl
cmake -G"NMake Makefiles" -S. -B./build -DGMX_GPU=off -DGMX_FFT_LIBRARY=mkl -DCMAKE_BUILD_TYPE=Release -DBUILD_SHARED_LIBS=off -DMKL_INCLUDE_DIR=“C:/Program Files (x86)/Intel/oneAPI/mkl/latest/include” -DMKL_LIBRARIES=“C:/Program Files (x86)/Intel/oneAPI/mkl/latest/lib/intel64/mkl_intel_lp64.lib;C:/Program Files (x86)/Intel/oneAPI/mkl/latest/lib/intel64/mkl_sequential.lib;C:/Program Files (x86)/Intel/oneAPI/mkl/latest/lib/intel64/mkl_core.lib”

then I ran nmake in the GROMACS source folder by running

cd build

From my (admittedly naive) perspective, the install seems to have worked since a gmx.exe file was created in the build folder. I put this executable into a separate folder (c:\gromacs\bin), created a folder "share (c:\gromacs\share) and copied the template and top directories into it, and transferred the folder “lib” over to c:\gromacs as well.

After all this, I tried to execute the gmx.exe executable and received the error message “This app can’t run on your PC.” (See the picture below). From perusing online, it looks like my version of Windows is not compatible with this version of GROMACS, but that doesn’t seem likely. Does anyone know what this could be due to?

These were some helpful instructions that I used: Compiling and running GROMACS natively on Windows | by Shoubhik R Maiti | CodeX | Medium


Thanks in advance for any help anyone can give!
Ryan Nieuwendaal

Try to run the application from an admin console. Also try to run it from the build folder rather then the install folder. And try to run it from Visual Studio (open the exe and run).

Running on Windows is barely tested. You might be better off running GROMACS under WSL then native.

Thanks for your reply. I was able to get around the error by executing gromacs directly in the bin folder (c:/gromacs-2022.2/bin) that it was built in. So, it looks like GROMACS was installed, but when I run the regression tests all but seven of them pass:

"The following tests FAILED:

  •     33 - GmxAnaTest (Failed)*
  •     41 - TrajectoryAnalysisUnitTests (Failed)*
  •     43 - ToolUnitTests (Failed)*
  •     48 - MdrunModulesTests (Failed)*
  •     50 - MdrunTestsOneRank (Failed)*
  •     51 - MdrunTestsTwoRanks (Failed)*
  •     55 - MdrunMpiTests (Failed)"*

I ran the regression tests both in the x64 Native Tools Command Prompt as well as in Visual Studio and I get the same response. (I took your advice and am now trying directly in the Visual Studio environment). In the manual it says that fails in the regression test are due to bugs in the compiler or due to too tight of precision, but I am not familiar enough with these tests to know which one it is. Is it critical that they all pass before moving forward, or can they be ignored?


If you run the test binary in the bin folder directly you should get extra information why it is failing.