Installation of gromacs 2020.4 - compute_80 error

GROMACS version: 2020.4
GROMACS modification: No
Here post your question
I am facing issues while undertaking local installation of Gromacs 2020.4 on a node with NVIDIA Tesla K40c GPU. The commands and errors are as follows -

** tar xfz gromacs-2020.4.tar.gz; cd gromacs-2020.4; mkdir build; cd build ** export PATH=/usr/local/cuda-10.1/bin/:PATH **** export LD_LIBRARY_PATH=/usr/local/cuda-10.1/lib64:LD_LIBRARY_PATH **** cmake … -DGMX_BUILD_OWN_FFTW=ON -DREGRESSIONTEST_DOWNLOAD=ON -DGMX_GPU=on -DCUDA_TOOLKIT_ROOT_DIR=/usr/local/cuda-10.1 -DCMAKE_INSTALL_PREFIX=home/user-bio/gromacs -DGMX_MPI=on -DGMX_GPLUSPLUS_PATH=/usr/bin/g++ -DCMAKE_C_COMPILER=mpicc -DCMAKE_CXX_COMPILER=mpicxx -DGMX_STDLIB_CXX_FLAGS=-stdlib=libc++ -DGMX_CUDA_TARGET_SM=“35;52;60;61;70;75;80”
$ make

[ 9%] Generating baseversion-gen.cpp
[ 9%] Building NVCC (Device) object src/gromacs/CMakeFiles/libgromacs.dir/nbnxm/cuda/
nvcc fatal : Unsupported gpu architecture ‘compute_80’
CMake Error at (message):
Error generating

src/gromacs/CMakeFiles/libgromacs.dir/build.make:63: recipe for target ‘src/gromacs/CMakeFiles/libgromacs.dir/nbnxm/cuda/’ failed
make[2]: *** [src/gromacs/CMakeFiles/libgromacs.dir/nbnxm/cuda/] Error 1
CMakeFiles/Makefile2:3077: recipe for target ‘src/gromacs/CMakeFiles/libgromacs.dir/all’ failed
make[1]: *** [src/gromacs/CMakeFiles/libgromacs.dir/all] Error 2
Makefile:162: recipe for target ‘all’ failed
make: *** [all] Error 2

$ nvidia-smi output is as follows-
| NVIDIA-SMI 418.39 Driver Version: 418.39 CUDA Version: 10.1 |
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| 0 Tesla K40c Off | 00000000:02:00.0 Off | 0 |
| 23% 43C P0 64W / 235W | 0MiB / 11441MiB | 83% Default |

| Processes: GPU Memory |
| GPU PID Type Process name Usage |
| No running processes found |

Could you please suggest a solution.
Thank you.

Hi all,
Can you please help me sort this issue?

Well, you provided the compute_80 target via flag:


So you should probably ensure that your GPU, driver and CUDA toolkit support it as the very first step.


Thank you @giacomo.fiorin for the suggestion.
I made necessary changes to the cmake command. I could overcome the issue posted earlier but I ended up with new ones. Here is a summary of the same:

$ make
TO overcome issues relating to
Issue 1) /usr/include/c++/5/bits/c++0x_warning.h:32:2: error: #error This file requires compiler and library support for the ISO C++ 2011 standard. This support must be enabled with the -std=c++11 or -std=gnu++11 compiler options.
#error This file requires compiler and library support \


Issue 2) src/gromacs/CMakeFiles/libgromacs.dir/build.make:471: recipe for target ‘src/gromacs/CMakeFiles/libgromacs.dir/nbnxm/cuda/’ failed

Edited the CMakeLists.txt to include:

Fix 1) SET(CMAKE_CXX_FLAGS “-std=c++14 -O3”) [ref: How to fix error This file requires compiler and library support for the ISO C++ 2011 standard?]

Fix 2) SET(CUDA_NVCC_FLAGS “${CUDA_NVCC_FLAGS} -std=c++14”) [ref: Compile error C++11 CUDA · Issue #818 · OpenKinect/libfreenect2 · GitHub]

Issue 3) Now I get the following errors -
[ 10%] Building NVCC (Device) object src/gromacs/CMakeFiles/libgromacs.dir/nbnxm/cuda/
/usr/local/cuda-10.1/include/vector_types.h(421): error: identifier “constexpr” is undefined

/usr/local/cuda-10.1/include/vector_types.h(421): error: member function with the same name as its class must be a constructor

/usr/local/cuda-10.1/include/vector_types.h(421): error: expected a “;”

/usr/local/cuda-10.1/include/vector_types.h(428): warning: parsing restarts here after previous syntax error

/usr/lib/gcc/x86_64-linux-gnu/5/include/stddef.h(436): error: identifier “nullptr” is undefined

Possible Fix 3) Ref - Colormap: make error · Issue #856 · colmap/colmap · GitHub suggests installation of gcc 9 on Ubuntu 16.04 (gcc version currently installed on the node is 5.4).

Is there any other way to overcome this issue or installing gcc and nvcc (newer compatible versions) is a necessity?( i am a non-root user)

Could you please suggest a solution.
Thank you.

P.S: I had no issues in installing Gromacs 2019.6 on the same node though.

Further info on the node -
$ lscpu
Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Byte Order: Little Endian
CPU(s): 64
On-line CPU(s) list: 0-63
Thread(s) per core: 2
Core(s) per socket: 8
Socket(s): 4
NUMA node(s): 4
Vendor ID: GenuineIntel
CPU family: 6
Model: 62
Model name: Intel(R) Xeon(R) CPU E5-4610 v2 @ 2.30GHz
Stepping: 4
CPU MHz: 1199.953
CPU max MHz: 2700.0000
CPU min MHz: 1200.0000
BogoMIPS: 4604.23
Virtualization: VT-x
L1d cache: 32K
L1i cache: 32K
L2 cache: 256K
L3 cache: 16384K
NUMA node0 CPU(s): 0-7,32-39
NUMA node1 CPU(s): 8-15,40-47
NUMA node2 CPU(s): 16-23,48-55
NUMA node3 CPU(s): 24-31,56-63
Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid dca sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm epb ssbd ibrs ibpb stibp kaiser tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms xsaveopt dtherm ida arat pln pts md_clear flush_l1d

Hi, pleast try starting from the beginning, i.e. by checking out the installation guide for that GROMACS version, which lists the compiler requirements, then compare those against the ones available on your system.

The documented recipe does not require you to manually edit CMakeLists.txt. Also, you do that while also mixing and matching instructions for unrelated software packages without knowing for sure if these are required, sufficient or neither. Your baseline expectation if you do that should be indeed getting more errors.

If you’re not an admin, please ask the admins to install the required packages if the OS is still maintained, or upgrade to a newer OS if it’s not.