Multiple energy groups is not implemented for GPUs

GROMACS version:2020.4
i was run this command

gmx mdrun -deffnm nvt -nb gpu

and got in

nvt.log

GPU info:
Number of GPUs detected: 1

Multiple energy groups is not implemented for GPUs, falling back to the CPU. For better performance, run on the GPU without energy groups and then do gmx mdrun -rerun option on the trajectory with an energy group .tpr file.

does energy group .tpr file is nvt.tpr ?

Hi,
energy group are defined in the parameter file (mdp file)
using the option

  • “energygrps”: group(s) for which to write to write short-ranged non-bonded potential energies to the energy file (not supported on GPUs)

You can modify the mdp file (removing the energy groups), re-generate an tpr file, perform the simulation using GPU, and then re-run following the instruction given in the error .

For mdp file option see

Best regards
Alessandra

thanks it’s done