Requested num of threads during make check

GROMACS version:2021.2
GROMACS modification: NO
I was using 2021.1 with no problems and decided to update to 2021.2. In using 2021.1 I had used "export OMP_NUM_THREADS=2 ( or 4 or 8) " at various times.
cmake and make appear to proceed with out error. But on make check the following error appear… tests to 52/73 pass
test 53/73 and beyond fail. A portion of the output after test 53/73 is:

[==========] Running 12 tests from 5 test cases.
[----------] Global test environment set-up.
[----------] 1 test from MdrunTest
[ RUN ] MdrunTest.WritesHelp
[ OK ] MdrunTest.WritesHelp (216 ms)
[----------] 1 test from MdrunTest (216 ms total)

[----------] 3 tests from WithDifferentOutputGroupSettings/MdrunCompressedXOutput
[ RUN ] WithDifferentOutputGroupSettings/MdrunCompressedXOutput.ExitsNormally/0
Generating 1-4 interactions: fudge = 0.5
Number of degrees of freedom in T-Coupling group rest is 9.00

NOTE 1 [file /home/pb/Desktop/gromacs-2021.2/build/src/programs/mdrun/tests/Testing/Temporary/WithDifferentOutputGroupSettings_MdrunCompressedXOutput_ExitsNormally_0_input.mdp]:
NVE simulation: will use the initial temperature of 2573.591 K for
determining the Verlet buffer size

NOTE 2 [file /home/pb/Desktop/gromacs-2021.2/build/src/programs/mdrun/tests/Testing/Temporary/WithDifferentOutputGroupSettings_MdrunCompressedXOutput_ExitsNormally_0_input.mdp]:
You are using a plain Coulomb cut-off, which might produce artifacts.
You might want to consider using PME electrostatics.

Program: mdrun-mpi-test, version 2021.2
Source file: src/gromacs/mdlib/gmx_omp_nthreads.cpp (line 183)
MPI rank: 0 (out of 2)

Fatal error:
Environment variable OMP_NUM_THREADS (1) and the number of threads requested
on the command line (2) have different values. Either omit one, or set them
both to the same value.

If I set the number of threads to 1, the first set of errors does not appear but later make check needs 2 threads and the error reappears.

using OMP_DYNAMIC=true does not help

I’ve updated cmake and g++ to v3.21 and 7.4 respectively. Linux Mint 19.2 Mate 1.22

It appears to need a method to disable the set environmental variable.

Regards
Paul