Single atom not being recognized as residue in CHARMM 36

GROMACS version:
GROMACS modification: No
Here post your question

Hello all

I am working with a pdb that contains only the atom sulfur forming a structure to be used in a simulation. I checked CHARMM 36 and it appeared as if it could handle the sulfur atom but when I perform this command:
gmx pdb2gmx

I get the error “residue ‘S’ not found in residue topology database”

Is this because it is alone? How do I trick gromacs to make this acceptable?


You can’t trick pdb2gmx - many have tried, all have failed ;)

What you need to do is add a suitable residue to the force field .rtp file (and perhaps others):

I don’t see an easy way to do this necessarily because you will have to modify charges of the S and any atoms to which it is bonded, which means creating several different (new or modified) residues, then modifying specbond.dat to recognize multiple bonds that act as cross-links. If it sounds too difficult, it’s probably because it is, and I do not think it is sensible to think of this S as some isolated species.

You need to create a fully modified residue that includes the S-containing prosthetic group, so you will need to parametrize and introduce one residue following the steps listed in the link above.

I worked through adding some parameters obtained via swiss param for iron and added them to these files:
to aminoacids.rtp
[ FE ]
[ atoms ]
FE FE 0.00 0

to atomtypes.atp
FE 55.847000

to ffnonbonded.itp
FE 26 55.8470 0.0 A 0.115817 0.000000

added to residuetypes.dat

But when I run pdb2gmx I get this error.
Problem with chain definition, or missing terminal residues.
This chain does not appear to contain a recognized chain molecule.
If this is incorrect, you can edit residuetypes.dat to modify the behavior.
8 out of 8 lines of specbond.dat converted successfully

Program: gmx pdb2gmx, version 2020.1-Ubuntu-2020.1-1
Source file: src/gromacs/gmxpreprocess/resall.cpp (line 557)

Fatal error:
Residue ‘FE’ not found in residue topology database

For more information and tips for troubleshooting, please check the GROMACS
website at

But I thought what I added to residuetypes.dat would correct that? Where am I going wrong?

That’s your problem. “FE” is not a chain type that pdb2gmx recognizes. You can choose Protein, DNA, RNA, Water, Ion, or Other.

If I switch “FE” to "Other’ pdb2gmx persists to dislike my molecule.

Please provide the full screen output from pdb2gmx. Uploading your input coordinate file would also be helpful.

The input file looks like this and contains only “FE” atoms.

501FE FE 1 9.513 6.335 1.773
502FE FE 2 2.679 7.226 1.639
503FE FE 3 6.852 9.310 1.540
504FE FE 4 9.408 3.243 1.805
505FE FE 5 1.990 2.138 1.617
506FE FE 6 3.567 9.571 1.572
507FE FE 7 8.066 8.241 1.666
508FE FE 8 6.557 2.049 1.371
509FE FE 9 5.930 9.025 1.495
510FE FE 10 1.255 6.487 1.092
511FE FE 11 1.990 2.138 1.617
512FE FE 12 9.429 5.151 1.673
513FE FE 13 4.720 0.112 1.008
514FE FE 14 6.212 8.307 1.243
515FE FE 15 9.541 5.187 1.128

Please copy and paste the whole screen output; this ending fragment is not enough. There’s lots that pdb2gmx does that may seem cryptic but is really important and potentially diagnostic. Upload the PDB file if you are willing.

The pdb file is just those atoms forming a tube where the iron atoms are touching each other to form the tube shape. But I am unable to upload the pdb file unfortunately.

As an update I got gromacs to recognize my ‘FE’ as an ion, but it still doesn’t like my residue for some reason.

Follow the link I provided above. You’re being told that there’s no entry in the force field .rtp file called FE.

So I opened the rtp for CHARMM 36, and I didn’t see an example of what an ion would look like in there. Where do you go to find out the format necessary for this file?

The manual has all file format specifications.