Why does < input option not work in Gromacs?

GROMACS version: 2019.4 (double precision)
GROMACS modification: Yes/No

I am trying to automate certain steps like:

gmx_mpi_d rms -s md.tpr -f md_PBC.xtc -o rmsd.xvg -tu ns < index

where index contains the options

But this isn’t working. I am getting

Program: gmx rms, version 2019.4
Source file: src/gromacs/topology/index.cpp (line 923)

Fatal error:
Cannot read from input

Same thing works for other sw. What is wrong? Noting mentioned in Using Commands in Scripts - Gromacs works. Is there something wrong in the sequence of my options?

IIRC this is actually an issue with MPI. Try using a gmx binary compiled without MPI support.

Thank you Dr Lemkul. MPI is the culprit here.