Acflen is not working with hbond command

GROMACS version: 2019.4
GROMACS modification: No

I am using GROMACS 2019.4 and trying to calculate ACF for H-binds. By default, the length of ACF is taken as half of the total length (i.e. 500 ns for a 1us run).

Now to change this length from 500 ns to 200 ns, I choose -acflen 20000 with total frames equals to 100,000. But, it always gives the ACF output flle (c(t) vs t) for 500 ns length (i.e. -acflen 50000 which is default).

I used the following command:
gmx_mpi_d hbond -f 1us_noPBC.xtc -s step7_1.tpr -num h_numbond.xvg -acflen 20000 -ac h_acf.xvg -dist h_distance.xvg -ang h_angle.xvg -life h_lifetime.xvg -r 0.35 -a 30 -noda

Am I missing something in the above command?


Did you find any solution to this issue?
I have the same question, why is it default to half of the simulation length?
Why can’t we change it?

This forum is practically useless. No one bothers to reply. Unfortunately the problem is not yet solved for me.

Hi Prithwish,
Please calm your tone.
People are doing this without any compensation. It is actually nobody’s job really.
So I think we shall respect their unconditional help whenever offered.
In my exp. sometimes people may take time to get back, especially if it is a very specific question related to a very specific option, which may be people have not really used/tried.
Or may be our question is based on half baked knowledge…

Lets try to re-word our question or read more literature/manual…