Dna-ligand rmsd graph analyze

GROMACS version:2020
GROMACS modification: Yes/No
I applied md simulation 100ns on my dna-ligand system.my simulation has finished successfully for 100ns for RMSD analyze My graph is below

but I couldnt understand this graph .Can anybody explain that what is the problem about this graph ?

Why do you think there is a problem?

I run my simulation for 100 ns but in the graph shows that 50 ns,my mdp file is below.I dont understand where is my wrong
integrator = md
dt = 0.001
nsteps = 50000000
nstxtcout = 50000
nstvout = 50000
nstfout = 50000
nstcalcenergy = 100
nstenergy = 1000
nstlog = 1000
cutoff-scheme = Verlet
nstlist = 20
vdwtype = Cut-off
vdw-modifier = Force-switch
rvdw_switch = 1.0
rvdw = 1.2
rlist = 1.2
rcoulomb = 1.2
coulombtype = PME
tcoupl = v-rescale
tc_grps = SOLU SOLV
tau_t = 1.0 1.0
ref_t = 310 310
pcoupl = Parrinello-Rahman
pcoupltype = isotropic
tau_p = 5.0
compressibility = 4.5e-5
ref_p = 1.0
constraints = h-bonds
constraint_algorithm = LINCS
continuation = yes
nstcomm = 100
comm_mode = linear
comm_grps = SOLU SOLV

You ran 50 ns.

how to extend my simulation from 50ns to 100 ns please

Start with the manual… Managing long simulations — GROMACS 2022.3 documentation

Sir,I read it how to extend my jobs
I want to run more 50 ns so,
$gmx convert-tpr -s step5.tpr -extend 50000 -o step5_1.tpr then,in order to run slurm I wrote
mpirun -np 40 /truba/sw/centos7.3/app/gromacs/2020-impi-mkl-PS2018-GOLD/bin/gmx_mpi mdrun $ntmpi -ntomp $ntomp -v -s -deffnm step5_1 -cpi step5.cpt -no append but İt has fail so could you help me how to fix it ?

Not without the exact error message, copied and pasted, please.

If you actually used this in your mdrun command line, it is simply an invalid option. It should be -noappend.

Sir without no append ,I am getting this error:
Program: gmx mdrun, version 2020-UNCHECKED
Source file: src/gromacs/mdrunutility/handlerestart.cpp (line 681)
Function: std::tuple<gmx::StartingBehavior, std::unique_ptr<t_fileio, gmx::functor_wrapper<t_fileio, gmx::closeLogFile>>> gmx::handleRestart(bool, int, const gmx_multisim_t *, gmx::AppendingBehavior, int, t_filenm *)
MPI rank: 39 (out of 40)

Communication (parallel processing) problem:
Another MPI rank encountered an exception

This is a generic MPI failure message. There should be a GROMACS-specific error in the .log file. But in any case, it is not my suggestion to omit -noappend, in fact the opposite. You probably should be using it, and just assemble your files later. There are often issues with appending.

two ways to do it. Either increase dt or the nsteps
dt=0.002 and nsteps=50000000
dt=0.001 and nsteps=100000000

I would recommend you to go with the 1st option