Md simulation analysis error

GROMACS version: version 2018.1
GROMACS modification: Yes/No
Here post your question
ı want to simulated my structure 100 ns so I changed nsteps from 500000 to 50000000 in the mdp file .My simulation is over.but for analysis when I write these commands
gmx trjconv -s md.tpr -f md.xtc -o md_new.xtc -pbc mol -center
gmx rms -s md.tpr -f md_new.xtc -o rmsd-protein.xvg -tu ns
xmgrace rmsd.xvg

time is showing 1ns but ı run my simulation for 100 ns
my mdp file is
integrator = md
dt = 0.002
nsteps = 50000000
nstxtcout = 50000
nstvout = 50000
nstfout = 50000
nstcalcenergy = 100
nstenergy = 1000
nstlog = 1000
cutoff-scheme = Verlet
nstlist = 20
vdwtype = PME
rvdw = 1.2
rlist = 1.2
rcoulomb = 1.2
coulombtype = PME
tcoupl = Nose-Hoover
tc_grps = SOLU SOLV
tau_t = 1.0 1.0
ref_t = 303.15 303.15
pcoupl = Parrinello-Rahman
pcoupltype = isotropic
tau_p = 5.0
compressibility = 4.5e-5
ref_p = 1.0
constraints = h-bonds
constraint_algorithm = LINCS
continuation = yes
nstcomm = 100
comm_mode = linear
comm_grps = SOLU SOLV
so Could you help me that where I have made wrong please ?

Did you recompile the .tpr file after changing nsteps? What does gmx check tell you about the contents of your .tpr and .xtc files?

gmx check -f step5.tpr it gives
Error in user input:
Invalid command-line options
In command-line option -f
File name ‘step5.tpr’ cannot be used for this option.
Only the following extensions are possible:
.xtc, .trr, .cpt, .gro, .g96, .pdb, .tng
so I check gmx check -f step5.xtc
Checking file step5.xtc
Reading frame 0 time 0.000

Atoms 146402

Precision 0.001 (nm)
Last frame 10 time 1000.000

Item #frames Timestep (ps)
Step 11 100
Time 11 100
Lambda 0
Coords 11 100
Velocities 0
Forces 0
Box 11 100
but md run I changed nsteps for 100 ns but after changed nsteps I couldnt recompile .tpr file also I dont know how to recompile .tpr file ?

After changing parameters in MDP file you need to use grompp to create the new tpr

I prepared my input file in step5_production.mdp file I changed num steps from 500000 to 50000000 for 100 ns and after that I used this command
gmx grompp -f step5_production.mdp -o step5.tpr -c step4.1_equilibration.gro -p -n index.ndx
before run md But result gives me just for 1 ns so Where is my fault ?

After used command which mentioned above I checked step5.tpr file using this command gmx dump -s topol.tpr | more
I shared screen and in the tpr file nsteps is 50000000

What command did you to launch mdrun with?

If you check the log file, how many steps does it say it simulated?

After this command gmx grompp -f step5_production.mdp -o step5.tpr -c step4.1_equilibration.gro -p -n index.ndx,to run md simulation,I am using gromacs-slurm $GROMACS_DIR/bin/gmx_mpi mdrun -deffnm step5
and I checked log file which is step5.log ,it shows 500000 but why ? in my mdp file nteps=50000000,log file is 500000,but why ? where am I missing ?
Input Parameters:
integrator = md
tinit = 0
dt = 0.002
nsteps = 500000
init-step = 0
simulation-part = 1
comm-mode = Linear
nstcomm = 100
bd-fric = 0
ld-seed = 1270568627
emtol = 10
emstep = 0.01
niter = 20

This suggests to me that grompp does not produce the new .tpr. What is the output from that command? Any warnings or errors? Have you tried in a new directory without other files?