DSSP not running

GROMACS version:
GROMACS modification: Yes/No
Here post your question
I am trying to perform DSSP calculation on my laptop with the following specification.
Processor AMD ryzon 5 4600H. GROMACS Version 2021.2 and version 2020.6.
Whenever I execute the command gmx do_dssp it is not running and stays at 0 frame and 0 time. I have tried for the smaller system with less than 10 frames to rule out the possibility of a ‘bulk’ system. The same system running without any issues in another system. I have copied the dssp executable from that system and tried. This resulted in the same condition where it is not running.

Anyone can give me any suggestion, why it is so

I even tried to run this on my nvme ssd, still no hope:
There are 374 residues in your selected group
dssp cmd=’/usr/bin/mkdssp -i ddi3musp 2>/dev/null’
Reading frame 0 time 0.000
Back Off! I just backed up ddi3musp to ./#ddi3musp.1#

I can see temp files are generated

What group you are selecting?
for me Main-Chain group (my case “group 5”) works perfect.
Surya

Does the file /usr/bin/mkdssp exist? You may need to install DSSP; I personally use version 3 from conda. If you have already installed DSSP (but not in /usr/bin) you will also have to set the DSSP variable to point to the mkdssp executable.

Will

It is all set and mkdssp work for individual PDB file.

If you are seeing temporary files generated, that suggests the program is working. Are the files getting replaced (e.g. the time stamp is updated?)

that is where the problem, the files are not getting replaced. @jalemkul

Try running the command it is trying to run (/usr/bin/mkdssp -i ddi3musp, or whatever the temporary filename is) and report back what error if any is reported.

Check that the temp files are not empty (should contain PDB lines)

Check that your DSSP is not version 4 (not supported yet)