Do_dssp run issues on MacOS Catalina

GROMACS version: 2020.2
GROMACS modification: Yes/No
Here post your question

I have downloaded dssp from:

Next, I set permissions and set executable in zsh shell using:
export DSSP=/Users/zrollins/DSSP/

Then, using gromacs2020.2 I have used command:
gmx do_dssp -f pullcf.xtc -s pullcf.tpr -n interfaceDEC.ndx -o ss.xpm -sc scount.xvg -a area.xpm -aa avgarea.xvg

I then select my index group of interest and receive no error messages, but does not progress through frame reads:
There are 9 residues in your selected group
dssp cmd=’/Users/zrollins/DSSP/ -i /tmp/filtervQhoz7 2>/dev/null’
Reading frame 0 time 0.000

Reading through online forums, this may be related to the binary execution file on MacOS? If so, how do I get the correct binary execution file for MacOS and how do I modify current DSSP directory to incorporate that?

I can’t find any directly applicable solutions online. Please help.

The $DSSP environment variable needs to point to the binary itself, not the directory in which it is located.

Thank you. I changed the env variable to the mkdssp executable, but got the same result. No frame progression:

There are 9 residues in your selected group
dssp cmd=’/Users/zrollins/DSSP/mkdssp -i /tmp/filterqRVDze 2>/dev/null’
Reading frame 0 time 0.000
Back Off! I just backed up /tmp/filterqRVDze to /tmp/#filterqRVDze.1#

I checked to make sure mkdssp was executing correctly by running a pdb file through mkdssp separately. Are there modifications that must be made to mkdssp to utilize for gromacs do_dssp?

If mkdssp works, then there is no problem. do_dssp is extremely slow so you may not see progress on the command line. Check to make sure that the temp files are being created over time (you will see them getting written and replaced periodically).

Interesting. I ran overnight and didn’t see the temp file get replaced (at least the file name).

I also tried setting the flag ‘-dt 1000’. The pull simulation was 5 ns and the index is just on 124 atom peptide. Same result after 2 hours.

Pull simulation files were acquired version 2019 and I am running on local machine version 2020.2. I will try using same gromacs version I acquired .xtc and .tpr files then report if this works. Any other suggestions?


I tried with gromacs 2019.1 and 2020.2 on MacOS Catalina. Both software installations were successful and mkdssp executable worked on pdb file. Possible bug on Mac OS Catalina v 10.15.5

I was able to get do_dssp working on the cluster that the pull simulations were generated.