Issue in called DSSP within do_dssp

GROMACS version:version 2020.1-Ubuntu-2020.1-1
GROMACS modification: Yes
Here post your question
Dear gmx developers,
I have issue of calling dssp and producing output within the gromacs wrapper function do_dssp, recently I have compiled dssp ( within ubuntu 20.04 installed as subsystem within windows 10) from source code downloaded from the site GitHub - PDB-REDO/dssp: Application to assign secondary structure to proteins and the dssp works fine as a standalone program, but if I move the dssp into /usr/local/bin folder and tried to execute the gmx do_dssp , the program does not produce any output and even there is no temp file which has any output of the progression of the ru.
I have seen similar post earlier in this forum but there is no solution posted (Do_dssp run issues on MacOS Catalina) . Can I get any solution for this.

The answer is what Justin Lemkul explained in the post you mentioned. You need to export the DSSP environment variable to the location of your dasp executable. Make sure the dssp executable is indeed executable. Also, remember that if you have not added the export command to your bashrc, you need to export it again after you exit your shell to be able to use do_dssp.

Thanks but the solution provided by Justin I tried already but it was not working for me and from the post it is apparent that the person was also not able to resolve the problem in spite of following export the DSSP environment variable as suggested by Lemkul. The issue is unable to diagnose as there is no proper error message pointing out this error and so it is impossible for me to figure out where the issue is within gromacs do_dssp program.
Before coming to this forum, I contacted DSSP developer team and they also tried to modify their source code back to their previous options to take input with the flags -i and -o enabled but still the error persist and the developers of the dssp given up and asked me to take up the issue with gromacs team and that’s why I am here looking for some useful suggestion.

I was not able to compile the version of DSSP you mentioned due to library version requirements, so I can not redo your steps. I currently use an old pre-compiled version of dssp (dssp_2.2.0) with Gromacs v2019.5 and everything works fine. An issue that I had was that gmx do_dssp did not recognize my export DSSP=/path/to/dssp-executable , if I typed the export command in the shell. It only worked after I put the export command in my ~/.bashrc file (and sourced it). You mentioned that your dssp(or mkdssp) works fine as a standalone(did you use a pdb file to check it?), so the only thing you need to do is to add the export command to your bashrc file and source your bashrc file again (source ~/.bashrc).

Thank you once again, yes the standalone DSSP able to work on pdb file and generate dssp output and I tried your suggestion also by including path in .bashrc and sourced but it did not work.
I would like to try the old version of Gromacs , probably the version that you are using Gromacs v2019.5 and will it be possible to get the compiled executable code of do_dssp alone of the earlier version ? could you please share the program do_dssp version v2019.5 compiled in ubuntu in windows 10 subsystem ? .

I need to clarify: I used this precompiled dssp file back in 2013 on Ubuntu 12.04 with a variety of Gromacs versinos (starting with v3.3 and up to v5.x). It also works on my current cluster (with Gromacs 2019.5) which is running CentOS Linux. So my understanding is that Gromacs version should not affect dssp functionality. I have not tried it on Ubuntu in windows 10. I could not find the exact version of my old dssp in the currently available archives, but you can find the older versions from their own github page: GitHub - cmbi/dssp: The DSSP building software

Many thanks for your support and the link you have shared for getting old version of DSSP is directing to other weblink where the old depository of DSSP available but unfortunately, the link does not have any old dssp source code, I will ask the DSSP developer about the old DSSP source code. Will update you here. Thanks again

It seems that the PDB files passed to mkdssp are not valid PDB format (tested with trjconf on Gromacs 2020.2 on an in-house trajectory). In order to add mmCIF support the parser in DSSP 4 had to be updated substantially which meant that it is now quite a bit more serious about file formats. Essentially what happens is that a PDB file is put in an mmCIF data structure.

Issues found with the output PDB file were:

  • Unnumbered REMARK records
  • Lack of a chain identifier
  • Residues with the same number that had different residue types but are not alternates of each other.

I think that DSSP4 will work once the files pushed to it are in PDB or mmCIF format. Note that DSSP2 is really obsolete now.

Try the DSSPold from this link as well:

Apologies for my Late reply . Though Non of the option and alternative suggested works for me in using DSSP within groamcs as of now …I thankful for all for your constructive discussion and suggestions for my post here.

Thank you but still the link not having any DSSPold repository

From the link above, on the left pane, under ‘miscellaneous’, click on ‘Distribution’, then at the bottom of the page you can see 3 links for DSSPold executables.

Thanks again, yes I could now download the DSSPold windows exe from the site and tried do_dssp but the issue is still persisting.

But again, the do_dssp producing first frame pdb file as output and only get stuck in producing dssp output file later and if I try that first frame saved as pdb produced by do_dssp as input file for dssp standalone , it produce the output successfully