Erorrs while using gromos54a7

GROMACS version:2021.2
GROMACS modification: No
GROMACS version:
GROMACS modification: Yes/No
Here post your question
Dear GROMACS users,

Though these problems have been discussed earlier, I would like to raise this topic again as the solutions seem confusing to me. I am new to GROMACS and facing multiple issues while preparing a system of protein in

spce water, much like the lysozyme tutorial, but using the GROMOS54a7 force field

(instead of OPLS/AA).

  1. For step 1: While using pdb2gmx to generate a .gro file, I get the following


Duplicate line found in or between hackblock and rtp entries.

I came across an archived mail that says these warnings arise due to some

typo in the ff.itp file. However, I have not tampered with the files that are

present in the gromacs library so any explanation as to what can be the source

of these warnings will be most helpful.

  1. The pdb2gmx step terminates with “successful” creation of the topology file.

However on closer inspection, I found out that certain fields corresponding to

bonds, angles and dihedrals are empty.

For bonds: The field corresponding to parameter c0 is missing for the 4 S-S bonds

present in my protein.

For angles: The field corresponding to parameter c0 is missing for the 4

CH2-S-S bond angles.

For dihedrals: The field c0 is absent for






The next two steps involving solvation proceeds smoothly but the ion addition

step terminates with the following error:

No default Proper Dih. types

I tried the same process with the lysozyme tutorial which is well documented

but instead of OPLS/AA I opted for the GROMOS54a7 force field and ended up

with the same kind of errors. Can anyone please tell me where I am going wrong?

Dear Aritra,

Check if you have installed Gromacs properly !
Try to continue with an older version (Installation instructions for Linux users: Installing Gromacs on Ubuntu for MD Simulation — Bioinformatics Review ).
I am using the version 5.1.1 and was able to generate the gro file and the topology file properly using the given forcefield GROMOS54a7.


Thank you for your reply. I checked with an older version of gromacs and its working properly but somehow failing with the newer version. I had no issues while installing. Anyway, my problem is solved as I have shifted to an older version of gromacs.