Error when running mdrun with gpu

GROMACS version: 2022.2
GROMACS modification: No
I tried to run my mdrun using this command, gmx mdrun -v -deffnm md_0_1 -nb gpu -bonded gpu -pme gpu -update gpu -pmefft gpu because I want to use the GPU. I already enable my GPU in gromacs as shown in the picture below. Does anyone have any idea why it cannot detect my GPU?


Hmm, its seems its visible from the error itself? It says you don’t have a compatible GPU, not sure if its too new, too old, does not have an SM version or just unsupported?

BS"D

You seem to be using a new version (11) of CUDA for the compiler, but the installed graphics driver is from version 10. You need to update your driver it seems.


I think its updated now. But still cannot run the md with gpu.

BS"D

There was a recent similar discussion, to which I answered that 2022 seems to need a new cuda toolkit flag when running cmake:

-DCUDAToolkit_ROOT=/whatever_path/cuda-11.1

Try that in place of, or in addition to the old flag (DCUDA_TOOLKIT_ROOT_DIR).

Harry

Hi, Thanks for the reply. I tried to uninstall and reinstall the gromacs with the cmake command you suggested, when i check my gmx version, it still shows cuda runtime: n/a.


Then i tried to run the md, and gpu still cannot be found.

BS”D

Do you have the

-DGMX_GPU=CUDA flag as well in the cmake line?

That also seems needed in 2022.

yes, I run this command during the installation process,

cmake … -DGMX_BUILD_OWN_FFTW=ON -DREGRESSIONTEST_DOWNLOAD=ON -DGMX_GPU=CUDA -DCUDA_TOOLKIT_ROOT_DIR=/usr/local/cuda-11.7 and it doesnt show any error during the installation.

Can you try running nvidia-smi? If it prints “Driver/library version mismatch”, you need to reboot your machine to reload the NVIDIA kernel module after it was installed/updated.


this is the result from running the command. It didn’t show any mismatch.