Glucose simulation in GROMACS

GROMACS version: 2018
GROMACS modification: No

Hi all

I am new to GROMACS and need help with some issues.

(1) I am trying to run a simulation for glucose in water. The topology file for glucose was generated using AMBER and GLYCAM_06j-1 force field, and then acpype was used to generate the GROMACS topology file. I have then solvated the system, and since the topology file was generated from a program other than GROMACS, I had to manually add the following line to the topology file: #include “tip3p.itp”, but when proceeded into minimization, I got the following error message: "This top-level .itp file has been removed. Edit your topology to include it from your force field directory instead, e.g. “oplsaa.ff/tip3p.itp”’. I am, however, not simulating a protein and not using any of the force fields provided with GROMACS, but I have tried editing the topology file as required and using different types of force fields, but each time I get the following error: [file tip3p.itp, line 7]: Atomtype OW not found. I have also tried using spc water instead of tip3p but without success. How can I resolve this issue?

(2) For the same glucose molecule, I am running another simulation in vacuum. I am using the group cut-off scheme, since verlet needs the periodic boundary conditions to be turned on, which cannot be the case for in vacuum simulation. In each run I get the following note: “The group cutoff scheme is deprecated since GROMACS 5.0 and will be removed in a future release when all interaction forms are supported for the verlet scheme. The verlet scheme already scales better, and it is compatible with GPUs and other accelerators”. Would it be safe just to ignore this note? Or does this have an effect on the accuracy of the calculation?

Your help is highly appreciated.

Shouldn’t it be include not inclusive?
see my definition of an spce water molecules

#include “oplsaa.ff/spce.itp”

With regards to the second part, have you tried going through Justin page that’s available at

Thank you @Teslim

This is just a typo here, but in the top file it is include. I have corrected it here.

I have tried adding this line #include “oplsaa.ff/spce.itp”, but without success, and I’ve also tried to replace oplsaa with all other force fields but none worked.

I’ve also gone through the Justin page, but couldn’t find what I want.
I have to say that the simulation went smoothly and the results are nice, but I want to make sure that the results are accurate

If you have a standalone topology from some other source, whatever generated it is going to assume that you only need the topology for that species, unlike pdb2gmx, which assumes you’re going to add more things along the way. Your problem is that the sugar topology doesn’t know anything about the nonbonded parameters or atomtypes for water. So you need to either add these to [atomtypes] in your topology or #include the parent AMBER force field (though with GLYCAM, since there are different 1-4 scaling factors, the latter option may not be appropriate without some modifications).

The Verlet scheme is more accurate but unfortunately vacuum simulations are not fully compatible with it. The solution I have seen proposed is to simply put your molecule in a huge box and run an NVT simulation. I haven’t tried that approach myself, though.

1 Like