Help on how to solve "atom N not found in building block 1ADE while combining tdb and rtp"

GROMACS version: 2020.1
GROMACS modification: Yes/No

Dear Gromacs users,

I downloaded the last version of the CHARMM36 ff from the MacKerell lab website and I intended to use this ff with pdb2gmx to obtain the topology of a pdb file that I have for a RNA sequence.

When running pdb2gmx it shows me the following error:
"atom N not found in building block 1ADE while combining tdb and rtp"

Now when checking the rtp for the FF I realized that there are not definition for 3’- and 5’-terminal nucleotides of a RNA sequence, or at least I can not find them. So it seems to me that the FF does not recognize the 1ADE (5’-adenosine) and the same will happen for the 3’-teminal CYT140. So the program can not find P or O1P or O2P, but this is my guess.
How could I correct this problem? Is there any way to add the 5- and 3’-terminal nucleotides to the .rtp file of the FF, or if they are there how to located them? What would be the name of these nucleotides in the rtp for CHARMM36?

As alternative solution I also generated the Gromacs compatible CHARMM36 topologies for this pdb using CHARMM-GUI. Is this a good enough solution?

Would appreciate any help with this.

Kindly,
Lazaro

You have to interactively select the appropriate terminal patches (5TER and 3TER), otherwise the first ones in the list (NTER and CTER, for proteins) get applied and pdb2gmx chokes on the missing atoms (which rightly shouldn’t be there).

Dear Dr. Jalemkul,

Thanks for the quick reply.

Do you refer with select the appropriately terminal patches to change the name of the atoms in my pdb to 5TER for example? I tried that and still get the same message.

Kindly,
Lazaro

Don’t change atom names. Select the appropriate patches (5TER and 3TER) when prompted by pdb2gmx.

Thank you very much Dr Jalemkul. I used -ter option for pdb2gmx and choosed 5TER and 3TER and it worked.

Thanks again