Huge difference in results depending on Gromacs version

GROMACS version: 2018.1, 2020.4
GROMACS modification: No

Hi all,

We have a porous solid membrane positioned in the XY-plane, which is automatically solvated with ions added, using gmx solvate and genion, respectively. We then proceed with EM, dynamic relaxation (semiisotropic barostat, box size constant in XY) and a production simulation under external field along Z. The final result is the ionic flux through the membrane, as calculated using a custom perl script. The whole process is scripted, the forcefield is custom (broadly based on OPLS-AA) and is inside the local directory every time the batch is started.

Up until we installed Gromacs v2020.4, all the results have always been consistent across versions (2018x, 2019x) on various architectures. With 2020.4, the batch proceeds happily and produces a massively different result. I know that some degree of variation is a must, but this looks very problematic. Here is an example.

Do we have a problem? I can share the entire set of inputs, if needed (preferably privately).



I think this is related to a bug we just got fixed for the 2020.5 point
release that should go out today or tomorrow.

Please look here for the description and how we fixed it:

And here for the fix:



Thanks Paul, I will wait for the new release. Did this bug affect anything not involving external fields? Basically, I have a set of simulation results entirely unrelated to what I described, and those used constant-force COM pulling, but no external fields. Do you think I should worry about those results? Thanks.

The new release is out now, so I would ask you to try it to see if the
issue has also been fixed for you.
Please check the release notes to make sure, but I don’t think any other
simulations had been affected.



I was hoping to. I just built it, but unfortunately, just like it was with 2020.4, sudo make install produces an inaccessible gromacs folder in /usr/local. I could change the permissions myself, but will defer to our sysadmin.

We never had this issue with earlier versions. Is there anything we should be aware of?

Thank you!


can you open a bug for this in our issue tracker (Issues · GROMACS / GROMACS · GitLab)?
I haven’t heard of this issue yet, can you check with your sysadmin on what is happening there and to help us with resolving this?



Hi Paul,

Our sysadmin’s solution is simple: sudo find /usr/local/gromacs -type d -exec chmod 755 {} ;
If you still want me to post on gitlab, I will.
In the meantime, 2020.5 does not have the issue I described, so it does indeed seem like you fixed it – thank you.