Index file error when running GMXPBSA2.1

GROMACS version: 2020.3
GROMACS modification: No
Here post your question

Dear all,

When I run the script gmxpbsa0.sh of the GMXPBSA2.1, I already get the following error:

Fatal error:
Index[5885] 5887 is larger than the number of atoms in the
trajectory file (5886)

whatever I use the trajectory containing the protein-ligand complex and the water and that only containing the protein -ligand complex. Do you have any idea how this error is caused?

Best regards.

Hi,
in general such a error occurs, when your select a index group that, as dimension (number of atoms), does not correspond to the number of atoms in your trajectory.
Using an index file generated from a trajectory frame usually solves the problem. To generate an index file use, gmx make_ndx.

Kind regards
Alessandra

Hello alevilla,

Thank you for you response. I use the md.gro which was generated simutaneously with the trajectory file MD.xtc in the MD simulation.
gmx make_ndx -f md.gro
This index file must have the same dimension with the trajectory, doesn’t it?
But the same error mentioned above comes out. So there might be other reason for it?

Best regards,

Hi,
Please note that not necessary the gmx mdrun output files, gro and and xtc , contain the same number of atoms.
What is saved in xtc file, depends on mdp option compressed-x-grps (group(s) to write to the compressed trajectory file, by default the whole system is written).

I have no experience in using the third-party tool GMXPBSA2.1, maybe someone else in the list has or you can directly contact the authors of the script.

Kind regards
Alessandra

Hi dear Dr Alevilla i want to use from GMXPBSA but i get below error. please guide me.

The Folder = that you indicated in the INPUT.dat file does not exist.
Exiting…

i set GMXPBSA Dir in bashrc as follows:
#for gmxpbsa 2.1.2
export GMXPBSAHOME=/home/proteininstitute/GMXPBSAtool

INPUT.dat (1.0 KB)