Restarted the simulation with checkpoint, but started from begining

GROMACS version:2021.2
GROMACS modification: Yes
Here post your question
I am running a simulation on a supercomputer using 500 core. The simulation is stopped after the wall time. when I submitted the job with the correct checkpoint file, the simulation started from the beginning. It restarted the simulation and replaced all the previously written file. I don’t find anything unusual with the log file. Unfortunately, the GROMACS is modified and I do not have any information regarding that.
(the commands are fine because later it worked fine )
The simulation I have started from the different directory and it worked fine. However, the same error occurred for a couple of jobs.
Any input would be helpful.


it’s difficult to tell what may be going wrong, especially since you are using a modified GROMACS version. Are you explicitly adding the -cpi option when running mdrun and providign the correct checkpoint file name? In case the checkpoint file cannot be found mdrun would start the simulation from the beginning, and as far as I know -cpi is not a default option.


You need to give -append flag

No, usually, it should work with -cpi.
The particular error occurred only during a certain period. It worked after that, so we suspect it is due to some other random reasons. We couldn’t reproduce the error even with same TPR file.