Segmentation fault

GROMACS version:
GROMACS modification: Yes/No
Here post your question
Dear All,
I am new to MD simulation. I was going through tutorial Membrane Protein: KALP15 in DPPC. I got the following error when i run:
Command line:
gmx genrestr -f KALP_newbox.gro -o strong_posre.itp -fc 100000 100000 100000

Reading structure file
Select group to position restrain
Segmentation fault (core dumped)

Who knows how to solve this?

Thank you

Best Regards

Known bug in version 2020 that has been reported many times. The tutorial was written for versions in the 2018 series, which work. Please use a 2018.x version to run the tutorial.

Hi :)
I’m receiving the same error while using gmx genrestr as well. How did you solve this problem?

Install version 2020.3. The bug has been fixed.


Thank you.

Hi Dr. Lemkul.
I installed gromacs 2020.3. At first eveything was perfect. Unfortunatly again I faced Segmentation fault while using “gmx genrestr” command.

@newbie I see you’ve already opened another issue about this on GitLab. You should make sure to highlight the fact that you are using 2020.3, where the fix was supposedly implemented. Otherwise, like my post, it will get marked as a duplicate and closed…

Is it listed as being version 2020.3 within the command that you run?

Very easy to run a different version if you have multiples installed.


I just tried reproducing this and commented on the Gitlab issue. It
really seems that you have not been using 2020.3, because I can’t
reproduce the segmentation fault with it.