Trjconv jumping DNA

GROMACS version:
GROMACS modification: Yes/No
Here post your question

I am currently facing a problem with erasing jumps from my system.
I have tried several different combinations of the trjconv command which worked for other systems I have made, but not for my current system.
I first tried only -pbc mol which worked fine before, then I tried to use the -pbc whole flag and (because the DNA was still jumping around) on top of that I used the nojump flag. After this command the visual output in VMD is a complete mess (see attached screenshot).
On top of that I tried to use not the tpr file fot the input but extracted the first frame of the trajectory, as described here:
before the nojump command, after the whole command it looks like this:
(so I guess it should be whole)

the commands I used:
1 )
gmx trjconv -s md_0.8DNA_3.tpr -f final_08DNA.xtc -o final_whole.xtc -pbc whole -center (1: DNA,0: system)
gmx trjconv -s md_0.8DNA_3.tpr -f final_whole.xtc -o final_nojump.xtc -pbc nojump -center (1,6:no-water)

It would be great if you could help me out here!

If you just want whole molecules, then what is wrong with the image you show after -pbc whole and before -pbc nojump? Another trick that often works for me is:
(a) pick an atom in the geometrical center and make an index group with only that one atom in it
(b) “gmx trjconv -pbc atom -center” and pick that one atom as the atom to center
you will have lots of broken waters, etc, but in many cases you will have an intact central molecule where other approaches can sometimes fail.

If you are really attempting to remove jumps, then I think the approach is to just do nojump as a single step without any -pbc whole or other commands first.

Hey :)
thanks for your answer! I have solved the problem already in adding some more steps…
I wanted a whole molecule which is not jumping aroung during the trajectory.
I figured out that I have to use a centered version of my gro file to get the trajectory fitting to that one :)