Xpm2ps output error with gromacs 2021

GROMACS version: 2021
GROMACS modification: No
With gromacs version 2021 xpm2ps makes a mess on x-axis of output .eps file (see attached file)
I tried many combinations of .m2p options, but could not find numbers which gives correct output file.
With gromacs version 2019 everything works fine.

I used this command:
gmx xpm2ps -f ss.xpm -o output.eps -di ps.m2p -by 8
with file attached

I found that similar behavior previously was characterised as a (solved) bug, but seems it is still here, or I miss something?


black&white = no ; Obsolete
titlefont = Times-Roman ; A PostScript Font
titlefontsize = 20 ; Font size (pt)
legend = yes ; Show the legend
legendfont = Times-Roman ; A PostScript Font
legendlabel = ; Used when there is none in the .xpm
legend2label = ; Used when merging two xpm’s
legendfontsize = 20 ; Font size (pt)
xbox = 0.2 ; x-size of a matrix element
ybox = 2.0 ; y-size of a matrix element
matrixspacing = 2.0 ; Space between 2 matrices
xoffset = 0.0 ; Between matrix and bounding box
yoffset = 0.0 ; Between matrix and bounding box
;— Axis options; x-axis —
x-major = 200 ; Major ticks on x axis every … frames
x-minor = 100 ; Id. Minor ticks
x-firstmajor = 0 ; First frame for major tick
x-majorat0 = yes ; Major tick at first frame
x-majorticklen = 10.0 ; x-majorticklength
x-minorticklen = 5.0 ; x-minorticklength
x-label = ; Used when there is none in the .xpm
x-fontsize = 16 ; Font size (pt)
x-font = Times-Roman ; A PostScript Font
x-tickfontsize = 10 ; Font size (pt)
x-tickfont = Helvetica ; A PostScript Font
;— Axis options; y-axis —
y-major = 10
y-minor = 4
y-firstmajor = 0
y-majorat0 = no
y-majorticklen = 8.0
y-minorticklen = 4.0
y-label =
y-fontsize = 16
y-font = Times-Roman
y-tickfontsize = 10
y-tickfont = Helvetica

Can you upload the xpm file? Would be easier to look into it with a full example

Increase these values and you won’t get so many tick marks. If you have a very long trajectory, it may be more appropriate to have ticks every few tens of ns rather than every 1-2 ns.

I have encountered this issue. When i tried with previous versions it was fine. Even at below cases
x-major = 10 ; Major ticks on x axis every … frames
x-minor = 0 ; Id. Minor ticks

Thanks, I thought it is of no relevance, but here it is:

Also, here is dssp command used:

gmx do_dssp -f  trajectory.xtc -s md.tpr -sc scount.xvg -o ss.xpm -tu ns -dt 0.1

Trajectory is 500ns long.

Thanks Justin
but unfortunately I already tried many combinations of numbers, tried to find the logic, but it just doesnt make a sense in 2021 version (everything worked fine with 2019).

Trajectory is not large, just 500ns.

ps. sorry for delayed answer, I was really busy with other things

Looked into it, I can reproduce the x-axis bug with 2021 base version, however it was fixed in a subsequent release.

With 2021.4, as well as current dev version, I get the expected result with regards to x-axis tick marks:

In any case, thanks for having taken the time to do such bug report!

Thank you so much…

(No facebook emoticons here, I really need them now to show appreciation for your support :) )