Create new tpr after changes in mdp file

GROMACS version: 2018
GROMACS modification: No
I have run 30ns md run. But now I have made changes in my mdp file to collect output after every 10ps instead of 2ps.
My concern is how to create new tpr file which can be used for further md run with continuation of my already 30ns output file?

I used the cmd: gmx grompp -f possibly-changed.mdp -c state.cpt - new.tpr
but it showed error saying state.cpt can not be used in this option.

If you wish to change the output frequency, you can supply the checkpoint file to gmx grompp with -t along with a new [.mdp] file.
See more gmx grompp — GROMACS 2022.2 documentation

Thank you for your response.
But I am still unable to troubleshoot my error.
I tried running the cmd and got the error:

gmx grompp -f md2.mdp -t state.cpt -o new.tpr

Program: gmx grompp, version 2018.1
Source file: src/gromacs/options/options.cpp (line 189)
Function: void gmx::internal::OptionSectionImpl::finish()

Error in user input:
Invalid input values
In option c
Required option was not provided, and the default file ‘conf’ does not
exist or is not accessible.
The following extensions were tried to complete the file name:
.gro, .g96, .pdb, .brk, .ent, .esp, .tpr

Thanks in advance.

I faced this error so many times before, I almost forgot now why it was.

Anyway, as Alexandra said, you need to create a new .tpr file from the changed .mdp
Justin has written great articles on managing long simulations. I think that’s what you are trying since you have used the exact prefixes for the files. But I don’t see your .top file in your command…

Try this:

gmx grompp -f new.mdp -p -c old.gro -t state.cpt -n index.ndx -o new.tpr

If you look through his MD tutorials, these commands are used for a basic start.
But in my case I had restart some of the simulations from the scratch as some of the previous files were either deleted or moved by mistake. But that’s for another day, when you don’t have previous sessions of simulation output files.

Thank you so much . This cmd worked and new tpr file is generated.

But when i provide mdrun, i didn’t get my desired results. The simulation started from zero steps rather than continuing from older steps.
I used the cmd:
gmx mdrun -deffnm new

Then I used another cmd:
gmx mdrun -s next.tpr -cpi state.cpt -noappend
This cmd started from continuation steps but it showed run for infinite ps

Then I tried another cmd to add time:
gmx convert-tpr -s new.tpr -extend time -o next.tpr
gmx mdrun -s next.tpr -cpi state.cpt -noappend
But i received same results of infinite ps

what else can i try to run this?

Thanks in advance

That’s a pity… well the old, new prefixes were to give you hints about what you need to put in those variables.

Could you please show us your exact file names from initial run of 30ns to mdp update to grompp new tpr creation?

On another note, you are saying you are using 2018…I am afraid there was a bug fix for 2018 for this sort of an issue. I am not sure if you are facing this.
see here:

I faced many issues with 2018 configurations too. Well my next suggestion may not be viable for you. But…is it possible for you to use at least 2019. 2019 Was a much better and still is a stable version to fancy.