Difficulties to download gromacs source code and regression testing files

GROMACS version: gromacs 2020.2
GROMACS modification: Yes/No
Here post your question I have been a gromacs user for about and year, but recently I tried to reinstall the 2020.2 version again but the regression test failed to download and I’m stuck in the installation process. Even when I tried to manually download the regression testing files through the browser it fails. Any help regarding this is highly appreciated. Thank you.

Hi,

The regression tests aren’t strictly necessary, they’re just nice to make sure your installation works correctly. You’ll likely be okay with disabling them.

On the other hand, this shouldn’t really fail. What error do you get when you try to download, or when you try to use the manually downloaded version?

Hey,

I have a similar problem.
I am installing Gromacs for the first time and I am unable to download the regression test as well as the actual software. the connection gets timed out, the last ligne on the prompt is ==>EPSV …
any help would be great.
Cheers

You can download them separately, see

but be sure to grab the right version.

Then, instead of using -DREGRESSIONTEST_DOWNLOAD, use the -DREGRESSIONTEST_PATH option as indicated here:

If that fails (as with OP), you can live without the regression tests, just remove the -DREGRESSIONTEST_DOWNLOAD line and it won’t try to run them. But try the other way first, since without the regression tests you can’t be as confident about the quality of the installation.