Installing older versions fails due to inaccessible regression test

GROMACS version: Anything before 2021
GROMACS modification: No

I’m trying to install GROMACS via CLI on Linux. I’ve noticed that following the install steps, I get the same issue for several different versions at this step:

cmake … -DGMX_BUILD_OWN_FFTW=ON -DREGRESSIONTEST_DOWNLOAD=ON

Namely, it cannot download the regression file. If you go to the download page for one of these pre-2021 releases, I noticed that all of the regression test links (1) have a link like this: http://**gerrit.**gromacs.or (can’t put >2 links, so I shortened URL) and (2) if you click on them you get a 403 forbidden error.

On a newer, 2021-and-later GROMACS version, the regression test link is like this:

https://ftp.gromacs.or

And clicking the link works (likewise, the CLI install process works as well). Swapping the “gerrit” for “ftp” doesn’t work in the original case.

I know these older versions are no longer supported, but wondering if there is a way to install them still? I need them to run some code that worked on an older version (has the “Group” cutoff-scheme, but the newer ones only accept “Verlet”… but that throws off the program given the other parameters in the *.mdp file).

Also I tried the version in this question ( gromacs.bioexcel.eu/t/unable-to-install-older-version-of-gromacs/4230), and ran into the same issue with the group cutoff-scheme.

Hi,

Concerning the regression tests, you can find the regression test for the version 2020.4 and older by looking at https://ftp.gromacs.org/regressiontests/ then select [regressiontests-XXXX.X.tar.gz] corresponding to the version you look for.(e.i for version 2020.3 https://ftp.gromacs.org/regressiontests/regressiontests-2020.3.tar.gz). I hope it works.

\Alessandra

Hello, that worked for me! I think.

I ran the install process without the regression tests, and then ran it afterwards inside the regression test folder