"Energy group exclusions" are supported or not? error during mdrun -membed

GROMACS version: 2020.3
GROMACS modification: No
Here post your question

Hello, everyone, i am new to gromacs, i just try to insert a membrane protein into dppc bilayer by using mdrun -membed command.

During creating the file .tpr by using grompp command:

gmx grompp -c prot+dppc+sol_solvdel.gro -p system.top -f g_membed.mdp -n index.ndx -o membed.tpr -maxwarn 2

i got this information:

ERROR 1 [file g_membed.mdp]:
Energy group exclusions are currently not supported

so i deleted the corresponding paragraph in g_membed.mdp file:

; Pairs of energy groups for which all non-bonded interactions are excluded

after that, it successfully creats membed.tpr file; but displays two warnings (i don’t know whether it matters, but it seems to be serious problems):

There were 2 warnings
double free or corruption (out)
Aborted (core dumped)

then when i try to use mdrun -membed command to insert the protein into the membrane:

echo PROTEIN_GMEMBED DPPC | gmx mdrun -membed membed.dat -s membed.tpr -mn index.ndx -v -c confout.pdb

it faced another error:

Input error or input inconsistency:
No energy exclusion groups defined. This is necessary for energy exclusion in the freeze group

since i can not find any sentence including energy exclusion groups in any of above files except membed.mdp,
and it also seems like the the energy group exclusions option is only exist in .mdp files (after searching the internet),
so i am just wondering whether there is a contradictory condition between grompp and mdrun -membed command? or the core dumped error cause this?
how to solve this problem?


Did you ever find a solution to this issue? I am also puzzled as to how one uses the membed tool when energy-exclusions are not supported.

The problem appears to be that membed relies on energy group exclusions, which are not supported with verlet cutoff. Since group cutoffs were deprecated this makes membed unusable in the recent versions of gromacs. Please correct me if I’m wrong.

@dkozuch, yes, you are right.
and the option is not support in the current version of GROMACS.

best regards