GMX_USE_RDTSCP=ON CMake option

GROMACS version: 2018.1
GROMACS modification: Yes/No
Here post your question

The current CPU can measure timings more accurately than the code in > gmx was configured to use. This might affect your simulation > speed as accurate timings are needed for load-balancing. > Please consider rebuilding gmx with the GMX_USE_RDTSCP=ON CMake option.

please who can make solve this problem?
i need help badly?

This is not really a problem but rather is a suggestion so that enabling the low level timing instruction would give you a better performance.
To do so, your should recompile the Gromacs having the GMX_USE_RDTSCP = ON in CMake step.
If I am not entirely wrong, it should be by default enabled if the Gromacs is compiled with enabled SIMD acceleration (DGMX_SIMD = xxx likes AVX2_256).

Cheers,
Salman Zarrini

please how can I recompile?
What are the steps involve?

Good luck

while you are in your build directory.
use

cmake … -DGMX_USE_RDTSCP=ON -DGMX_SIMD= /Pick the ideal SIMD option for your CPU from the installation guide/
(It is a double dot after cmake command, idk why it is formatting double dot as triple)

you can add more options(e.g double precision, gpu and cuda support) simply by visiting here and pick the best which suits your needs