Install NetworkX package, version 1.11

GROMACS version: 2020.1
GROMACS modification: Yes/No
I want to install the NetworkX package, version 1.11 in order to execute the “python JZ4 jz4_fix.mol2 jz4.str charmm36-mar2019.ff” script. I am not able to find the correct place to install this. Kindly suggest a solution for this. Thanks for reading this question.


I did:

install python2
pip install networkx==1.11

1 Like

@claudia is right on, but also note that the old version of NetworkX is no longer required. We offer several versions of the script for different Python and NetworkX versions that the user might have. We support Python3 and NetworkX 2.x now.

Thank you for your valuable reply. I will try it out.

I have python 3.8 and networkx 2.4, but gromacs running gives me the following error. please suggest the right way

This script has been tested with NetworkX 2.3, and 2.4 is buggy.
Please install version 2.3 for best performance:
pip uninstall networkx
pip install networkx==2.3
NOTE 1: Code tested with Python 3.5.2 and 3.7.3. Your version: 3.8.3 (default, Jul 2 2020, 16:21:59)
[GCC 7.3.0]

NOTE 2: Code tested with NetworkX 2.3. Your version: 2.4

This is not a GROMACS issue, but one with the CGenFF conversion script. The pip install command should do the trick but if not, then you need to investigate what’s going on with your Python distribution.

  • just skeptical if i use “pip install networkx2.3”, will it be compatible with the python 3.8?
  • networkx2.3 compatibility is with python 3.5, 3.6, 3.7

If your pip is from the Python3 package, yes.

Hi I have python3 and Networkx 2.3 version installed
But when I run the command JZ4 jz4_fix.mol2 jz4.str charmm36-mar2019.ff
the following message appears. Unable to understand what to do ?
File “”, line 991, in if(float(nx.version) < 2.0): ValueError: could not convert string to float: ‘2.5.1’
I am using gromacs-2021.5 version

Hi Hyma, did you solved it to problem?

Thanks for your concern. I am glad that I solved the problem.