invalid order of directives cmaptype

Hi everyone,

I’m trying to minimize the energy of a simulation box with acetonitrile. I obtained the .pdb file and by using gmx pdb2gmx I obtained a topology file (CHARMM 36-jul2020 force field is used). When I proceed to run the gmx grompp, I get an error:
Fatal error:
Syntax error - File cmap.itp, line 4
Last line read:
‘[ cmaptypes ]’
Invalid order for directive cmaptypes

I’ve tried to separate the topology file with the force field file and the molecule information file, each in a separated .itp file:

#include “charmm36-jul2020.ff/forcefield.itp”
#include “/home/ubuntu/thesis/ini_files/CCN/CCN.itp”

[ system ]
; Name

[ molecules ]
; Compound mols
Other_chain_A 1

I still get the same error. And when I’ve shifted any of the parts the error is the same but changing the directives.

Can anyone help me out? Any kind of suggestion on how to fix it will be very appreciated.

Thank you!

Andreu Mor

the directive ‘[ cmaptypes ]` is located the force field files. Thus the natural question is where you got the force field files.
Did you get the ff files from MacKerell Lab? Or Did you use a modified version? In the case, there may be a mistake in setting the modifications
or maybe you got some warning once you run gmx pdb2gmx.
Best regards