Pdb2gmx looking in wrong directory even though I changed GMXLIB

GROMACS version: 2016.5
GROMACS modification: No


I am trying to make a topology for N-methyl acetamide using GROMOS 53a6 ff. This force field doesn’t have an entry for NME (N-methyl capping group), but Tom Piggot from the GROMACS forum provided an rtp file. I put the rtp file in the same directory as the rest of the force field files (gromos53a6.ff) and copied it to my local directory. I then changed GMXLIB to the current working directory based on the pdb2gmx documentation. I now get this error:

Feature not implemented:
Can only select the first of multiple force field entries with directory name
’gromos53a6.ff’ in the list. If you want to use the next entry, run pdb2gmx in
a different directory, set GMXLIB to point to the desired force field first,
and/or rename or move the force field directory present in the current working

As a side note, is having an rtp file enough to specify the topology for NME? If no, what else do I need and can anyone provide it? People in the literature have done simulations with NMA and this ff so it must be pretty straightforward (I think)…

Thank you!


I suggest to check GMXLIB setting of your shell. you can look at the environmental setting using the bash command ( > env | grep ‘GMXLIB’ ).
I think that pdb2gmx writes in standard output where is looking for forcefield file. This should be the case also for 2016, but I am not 100% sure.

I guess that you have added the rtp entry to rtp file. here you can find some information on how to add a residue Adding a Residue to a Force Field — GROMACS 2021.4 documentation