Periodic Boundary Conditions Error, Molecule Trajectory Collapses to 2D

GROMACS version: 2020.4
GROMACS modification: No

I have been running simulations of small proteins in water. Nothing fancy. Have been doing them without a hitch for awhile now. This last one I tried to do, however, behaved very strangely.

The simulation seems to run for 125ns without any problems, but when I try to do any calculations with the output .xtc trajectory (protein atoms only), I run into a problem. For example, using gmx traj to calculate center-of-mass trajectories for groups, I get this error about 2ns in:

Fatal error: There are inconsistent shifts over periodic boundaries in a molecule type consisting of 1231 atoms. The longest distance involved in such interactions is 3.749 nm which is above half the box length. Either you have excessively large distances between atoms in bonded interactions or your system is exploding.

So naturally the first thing I did was try to visualize the trajectory in VMD. It’s a globular protein, well-folded, and everything looks fine at first. Then VMD abruptly crashes with no message at the exact same timestamp.

Since it has something to do with periodic boundary conditions, I tried using gmx trjconv with -pbc nojump to visualize the trajectory without them. Now VMD doesn’t crash, but I see that the entire protein jumps one box length at that timestamp, and even worse, all the x-coordinates collapse to a single value and my protein becomes 2D. This value still seems to diffuse and the simulation is obviously still proceeding. I can confirm that all the x-values are the same using gmx dump.

I honestly have no clue what is happening, and I’m trying to figure out if this run is at all salvageable or if I must start over. Even if I have to start over though, I would like to know what I did wrong so that it doesn’t happen again. I am at a bit of a loss as to what happened since the simulation seemed fine for 2 ns. I will probably try redoing the simulation with a larger box, but I would like to understand what happened.

Thank you for any help.

This sounds very strange. Does the run continue with reasonable energies and temperatures reported in the log or energy file? If so, my guess is that your trajectory file somehow got corrupted (not due to GROMACS).