Problem with orientational restraints

GROMACS version: 2020
GROMACS modification: No
Hi everyone, I am facing with one pretty annoying problem while setting up a protein simulation with orientational restraints (RDC data from NMR). I’ve searched everywhere for an answer and it look like on one person had similar problem, but never posted a solution.
I am setting up simulations and for a test I am trying to incorporate some constraints to protein .itp file right after all bonded interactions (I also tried to relocate it to the corresponding place in the file – same result):
[ orientation_restraints ]
;ai aj type exp. label alpha const. obs. weight
32 33 1 1 3 3 6.083 2.9235 1.00
52 53 1 1 4 3 6.083 9.8683 1.00
55 56 1 1 5 3 6.083 -13.2275 1.00
66 67 1 1 6 3 6.083 -8.1949 1.00
102 103 1 1 7 3 6.083 2.9235 1.00
166 167 1 1 8 3 6.083 3.9235 1.00

after that I add this to mdp file (here is an example for final md run, but I also tried it on any step nvt, npt – same problem):
orire = yes
orire-fc = 1 ; Orientation restraints force constant
orire-tau = 0 ; Turn off time averaging
orire-fitgrp = backbone

I run : gmx mdrun -v -dlb yes -update cpu -deffnm md_0_1

and get this error:
Fatal error:
Found 44630 copies of a molecule with orientation restrains while the current
code only supports a single copy. If you want to ensemble average, run
multiple copies of the system using the multi-sim feature of mdrun.

As 44630 is exact number of my SOL molecules I assume that for some reason the constraints are applied to them, not the protein molecule. Maybe someone can help? I can upload all my file, but those are pretty standard and if I remove “orire= yes” everything works. Thank you for looking.

Please attach all input files for grompp so I can check what the issue is.

Thank you. As a new user it doesn’t allow me to upload a file. One think I discover, it looks like it runs in gromacs 2016.4

2016 does not have the check that gave the error in 2020, so we don’t know if your results are correct or not.
I tried a similar system with protein+water in 2020 and I did not get the error.
You should at least be able to upload the top and itp files. Could you dod that? If that doesn’t work, could you upload the input files for grompp somewhere else and post a link?

please take a look at the files (this is the same system, but has more restraints):

I don’t know if you have the same problem with the system on dropbox as with the system you first posted about. To me this seems to be a different issue, but maybe not? The issue here is that there seems to be a check missing in Gromacs and I get an assertion failure about orires type indices not being consecutive. The code is written for a single molecule only, but there is no check for this. You could solve this by merging the two chains into one moleculetype. I can also see if I can fix this issue, but I’m currently very busy.

i am facing the same problem, regardless where i place the include for the itp file of the orientation restraints, it somehow always applied to the solution molecules not the protein. where you able to fix the problem

I have not had time to write a fix.

Do you also have two chains to which you apply orientation restraints?

Unfortunately I have not find a fix yet.

No, my system is simple i have a 83 residue helical protein solvated in water, and i want to apply experimental residual dipolar coupling data for the last helix to see if the gromacs md simulation can retrieve a correct trajectory of the dynamic movements of the last helix. there are 4 rdc data (N-H,C-H etc) from 2 alignment media for each residue. However i always get the same error:
Fatal error:
Found 5389 copies of a molecule with orientation restrains while the current
code only supports a single copy. If you want to ensemble average, run
multiple copies of the system using the multi-sim feature of mdrun.

what am i doing wrong? I have attached my top , md,tpr,and itp file
I hope you can explain to me what is the problem and how to fix it.
Thank you

md.mdp (7.36 KB)

(Attachment RDC-restraint.itp is missing) (362 KB)

(Attachment 1a1z-d.tpr is missing)

(Attachment 1a1z-NPT.gro is missing)

That is interesting! I thought this issue was related to multiple
chains. Your system should be useful for debugging this. The forum does
not seem to allow uploads of certain file types. Could you upload your
files somewhere else and post a link?

I have shared the folder with the fles down

Also note that when i tried the same system in vacuum, the rdc where implemented correctly, this error only appears after solvation is done.
If you have any questions or notes please share, i appreciate the help and feedback
Hanin Oar

Thanks. But I cannot reproduce the error. Which version are you using? This looks like a bug that was fixed for version 2020.1.