Energy minimization has stopped

Hi,
I run
gmx grompp -f em.mdp -c solv_ions.gro -p topol.top -o em.tpr

gmx mdrun -v -deffnm em

and I obtained the following error:

Steepest Descents:
Tolerance (Fmax) = 5.00000e+02
Number of steps = 10000
Step= 0, Dmax= 1.0e-03 nm, Epot= 2.43069e+22 Fmax= inf, atom= 4698
Step= 10, Dmax= 2.0e-06 nm, Epot= 2.43069e+22 Fmax= inf, atom= 4698
Energy minimization has stopped because the force on at least one atom is not
finite. This usually means atoms are overlapping. Modify the input
coordinates to remove atom overlap or use soft-core potentials with the free
energy code to avoid infinite forces.
You could also be lucky that switching to double precision is sufficient to
obtain finite forces.

writing lowest energy coordinates.

Back Off! I just backed up em.gro to ./#em.gro.2#

Steepest Descents converged to machine precision in 11 steps,
but did not reach the requested Fmax < 500.
Potential Energy = 2.4306918e+22
Maximum force = inf on atom 4698
Norm of force = inf

Some suggestions?

Hi,
I suggest:

  • check your starting structure by looking at atom 4698, maybe some error occur when you built the starting structure and you have two overlapping atoms
  • maybe you have one solvent molecule overlapping with another molecule, in that case remove it
  • check the energy minimisation parameter in mdp file maybe some values are not suitable for your case (e.i maybe step value is too large)

Kind regards

1 Like