Error while loading shared libraries

GROMACS version: 2020.5
GROMACS modification: No

Energy minimization and equilibration steps were finished with no problem, but when I ran NPT production, I get the following error:

gmx_mpi: error while loading shared libraries: cannot open shared object file: No such file or directory

Has anyone faced similar error as this? or does anyone have idea of how to go about solving this issue?

Thank you in advance.

libmxm is a Mellanox library. It is likely that the MPI library used at your cluster is built with libmxm, however the runtime configuration you are using is not finding it.

Check you cluster documentation on how to run MPI jobs (may need something like module load mpi in your batch scripts). Failing that, contact the person responsible for your cluster, describe the problem and ask how to run MPI jobs with the proper environment.

Thank you for the explanation and suggestion.

Apparently, there has been some issue with the MPI library, so a representative from my school server suggested not to do use MPI (i.e. gmx instead of gmx_mpi), which solved the issue.