Issue with MPI

GROMACS version: 2021.3
GROMACS modification: Yes/No
Here post your question
I am trying to run protein-ligand MD simulation using slurm script on HPC system.
But I am getting the following error (screenshot attached). Any suggestion to solve this error would be highly appreciated.


MPI_ABORT was invoked on rank 0 in communicator MPI_COMM_WORLD
with errorcode 1.

NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
You may or may not see output from other processes, depending on
exactly when Open MPI kills them.

No executable was specified on the mpirun command line.


  1. What full command did you use?
  2. does that .cpt file giving you the input/output error actually exist?
  3. did you compile gmx with MPI?
  4. can you run this in serial without MPI (useful debugging info)?
  1. The screenshot is attached for you to look at the code.
    Let me know if I am doing it correctly or not.
  2. There is no mention of error in .cpt file.
  3. Could you tell me more about it.
  4. Yes, I tried this in serial. It worked fine.

Looking forward to your response!


  1. Check your first post. There is an error message indicating that a .cpt file does not exist. I am therefore surprised that things worked with serial gmx. Maybe that’s just the way things work now.

  2. cmake -DGMX_MPI=ON would be necessary to compile the mpi executable (which I believe is by default going to be names gmx_mpi not gmx). See here: