Gmx make_ndx using em.tpr. Fatal error: No v in input file

GROMACS version: 2023
GROMACS modification: Yes/No
Here post your question


SO I am trying to create an index file using gmx make_ndx using a em.tpr file post energy minimization. I get a fatal error : No v in input file.

On checking the em.tpr file, I see the following:

x[20381]={ 4.57400e+00, 4.52200e+00, 5.54700e+00}
x[20382]={ 3.76100e+00, 5.03400e+00, 5.00600e+00}
x[20383]={ 4.25100e+00, 5.84200e+00, 3.28000e-01}
v: not available
Group statistics
T-Coupling : 20384 (total 20384 atoms)
Energy Mon. : 20384 (total 20384 atoms)
Acc. not used: 20384 (total 20384 atoms)

As you can see the v not avaibale is mentioned. Please help me with this issue as I am unable to go further in preparing files for production run with index files. Thanks.

Please post your actual command, the selections you tried to make, and the full (copied and pasted) error message from the terminal. It seems clear that the input file has velocities that you’re trying to use in some way, which an energy minimization input won’t have.

Thanks for replying.

So I create an em.tpr file using the following commad:
gmx grompp -f minim.mdp -c 6bjv_ions.gro -p -o em.tpr

The minim.mdp file has the following entries:

integrator = steep ; Algorithm (steep = steepest descent minimization)
emtol = 100.0 ; Stop minimization when the maximum force < 100.0 kJ/mol/nm
emstep = 0.001 ; Minimization step size
nsteps = 50000
constraints = h-bonds
cutoff-scheme = Verlet
vdwtype = cutoff
vdw-modifier = force-switch
rlist = 1.2
rvdw = 1.2
rvdw-switch = 1.0
coulombtype = PME
rcoulomb = 1.2
DispCorr = no

Next , After running energy minimization via gmx mdrun -v -deffnm em

I try to create a index file using this command: gmx make_ndx -f em.tpr -o index.ndx
To which I get this:
Fatal error:
No v in input file

On checking the em.tpr file, velocities are not being written :

Not sure, why this is happening.

This is one of the em.tpr outputs from a previously successful simulaion. The velocity assigned at minimization step is zero but the entries are still there. But what would the work around to create index files using this tpr file? Thanks!


Instead of taking em.tpr file I created the index file using the em.gro file, it doesn’t have any entry for velocities so make_ndx didn’t throw any error. this should be fine i think!

Why don’t you try the following manner? subha24 has already mentioned the same.

gmx make_ndx -f xxx.gro -o yyy.ndx

xxx = name of the gro file

yyy = name of the index file

I get the same error with my recently installed 2023.1. My old scripts using 2021.5 worked fine so this must be a relatively new behaviour. make_ndx should not need velocities so I would consider this a minor bug. Can’t make a redmine issue at the moment because the site seems broken.

Redmine died long ago :) Please file the issue in GitLab: Issues · GROMACS / GROMACS · GitLab

Haha. Yes I forgot that. Thanks.

Quick testing showed that make_ndx 2023.1 can work with an older tpr file for em. So it seems that make_ndx is not to blame, but grompp appears to have changed how it writes the tpr files. It would be good if make_ndx could handle tpr files of the same version also without velocities however, so maybe the fix should be made to make_ndx. Will file an issue.